POJ3356-AGTC(编辑距离)

AGTC

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13042 Accepted: 4917
Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

Deletion: a letter in x is missing in y at a corresponding position.
Insertion: a letter in y is missing in x at a corresponding position.
Change: letters at corresponding positions are distinct
Certainly, we would like to minimize the number of all possible operations.

Illustration
A G T A A G T * A G G C

| | | | | | |

A G T * C * T G A C G C
Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct
This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A G T A A G T A G G C

| | | | | | |

A G T C T G * A C G C
and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC
Sample Output

4
Source

Manila 2006

题目大意: 求两个字符串之间的编辑距离
解题思路: dp
对于串 a[1...n],b[1...m]

dp[i][j]=dp[i1][j1] a[i]==b[j]

dp[i][j]=mindp[i1][j]+wdel(a[i])dp[i][j1]+wins(b[j])dp[i1][j1]+wsub(a[i],b[j]) a[i]!=b[j]

边界:
dp[i][0]=ik=1wdel(a[k])
dp[0][j]=jk=1wins(b[k])

#include<iostream>
#include<cstring>
#include<string>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<map>
#include<set>
#include<cmath>
#include<cctype>
#include<cstdlib>
#include<list>
#include<iomanip>
using namespace std;
typedef long long LL;
const int MAXN=1e3+10;
const int INF=0x3f3f3f3f;
char a[MAXN],b[MAXN];
int dp[MAXN][MAXN];

int main()
{
    int n,m;
    while(cin>>n)
    {
        cin>>a;
        cin>>m>>b;
        memset(dp,0,sizeof(dp));
        for(int i=0;i<=n;i++)
        {
            dp[i][0]=i;
        }
        for(int j=0;j<=m;j++)
        {
            dp[0][j]=j;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(a[i-1]==b[j-1])
                    dp[i][j]=dp[i-1][j-1];
                else
                    dp[i][j]=min(dp[i-1][j]+1,min(dp[i][j-1]+1,dp[i-1][j-1]+1));
            }
        }
        cout<<dp[n][m]<<endl;
    }
    return 0;
}

空间优化:

#include<iostream>
#include<cstring>
#include<string>
#include<vector>
#include<algorithm>
#include<cstdio>
#include<map>
#include<set>
#include<cmath>
#include<cctype>
#include<cstdlib>
#include<list>
#include<iomanip>
using namespace std;
typedef long long LL;
const int MAXN=1e3+10;
const int INF=0x3f3f3f3f;
char a[MAXN],b[MAXN];
int dp[MAXN];

int main()
{
    int n,m;
    while(cin>>n)
    {
        cin>>a;
        cin>>m>>b;
        int tl,tmp;
        memset(dp,0,sizeof(dp));
        for(int j=0;j<=m;j++)
        {
            dp[j]=j;
        }
        for(int i=1;i<=n;i++)
        {
            tl=i-1;//top left
            dp[0]=i;//left
            for(int j=1;j<=m;j++)
            {
                tmp=dp[j];
                if(a[i-1]==b[j-1])
                    dp[j]=tl;
                else
                    dp[j]=min(dp[j]+1,min(dp[j-1]+1,tl+1));
                tl=tmp;
            }
        }
        cout<<dp[m]<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值