[poj 1019] Number Sequence 数学 想法题

Number Sequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37345 Accepted: 10777

Description
A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2…Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)

Output
There should be one output line per test case containing the digit located in the position i.

Sample Input

2
8
3

Sample Output

2
2

Source
Tehran 2002, First Iran Nationwide Internet Programming Contest

题目链接http://poj.org/problem?id=1019
题意:有一串数字串,其规律为

1 12 123 1234 12345 123456 1234567 12345678 123456789 12345678910 1234567891011 123456789101112······k

输入位置n,计算这一串数字第n位是什么数字,注意是数字,不是数!例如12345678910的第10位是1,而不是10,第11位是0,也不是10。总之多位的数在序列中要被拆分为几位数字,一个数字对应一位。
思路:
(int)log10((double)i)+1

(i-1)/(int)pow((double)10,len-pos)%10 计算位置

代码
s[i]:i组长度的前缀和;
a[i]:i组的长度
对任意一个数所占的空间很好求,即 (int)log10(k)+1;

#include<iostream>
#include<stdio.h>
#include<math.h>  
#include<algorithm>
using namespace std;

long long a[31270],s[31270];

void pre()
{
    a[1]=1;
    s[1]=1;
    for(int i=2;i<31269;i++)
    {
        a[i]=a[i-1]+(int)log10((double)i)+1;
        s[i]=s[i-1]+a[i];
    }

}
int cal(int n)
{
    int i=0;
    while(s[i]<n) i++;  //找在那组
    int pos=n-s[i-1];  //找在那位置
    int len=0;
    int j;
    for(j=1;len<pos;j++)
    {
         len+=(int)log10((double)j)+1;  
    }     //找在那个数
    return ((j-1)/(int)pow(10.0,len-pos))%10;  
    //在i数的len-pos位置的数字;

}
int main()
{
    pre();
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",cal(n));
    }

}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值