杭电 1002 大数相加 【关键语句:sum=a[i]-'0'+b[j]-'0'+carry;c[i]='0'+sum%10;//-‘0’字符串转换成数字-‘0’,数字转换成字符串+‘0’】

36 篇文章 0 订阅
33 篇文章 0 订阅

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 324547    Accepted Submission(s): 63050


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
#include<stdio.h>
#include<string.h>
int main()
{
    char a[1024],b[1024],c[1024];
    int n,t,l1,l2,l,i,j,carry,sum;
    while(EOF!=scanf("%d",&n))
    {
        for(t=0;t<n;t++)
        {
            if(t!=0)
                printf("\n");
            carry=0;
            memset(a,0,sizeof(a));
            memset(b,0,sizeof(b));
            memset(c,0,sizeof(c));
            scanf("%s%s",&a,&b);
            
            l1=strlen(a);l2=strlen(b);
            
            if(l1>l2)
            {    
                for(i=l1-1,j=l2-1;j>=0;i--,j--)
                {
                    sum=a[i]-'0'+b[j]-'0'+carry;//由字符串转换为数字——-‘0”
                    //这句还有个error,就是自动默认了i和j相等= =
                    c[i]='0'+sum%10;//由数字转换为字符串
                    carry=sum/10;
                }
                for(;i>=0;i--)//处理剩下一部分
                {
                    sum=a[i]-'0'+carry;
                    c[i]='0'+sum%10;
                    carry=sum/10;
                }
            }
            else
            {
                for(i=l1-1,j=l2-1;i>=0;i--,j--)
                {
                    sum=a[i]-'0'+b[j]-'0'+carry;
                    c[j]='0'+sum%10;
                    carry=sum/10;
                }
                for(;j>=0;j--)
                {
                    sum=b[j]-'0'+carry;
                    c[j]='0'+sum%10;//和上面的不太一样啊...
                    carry=sum/10;
                }
            }
            l=l1>l2?l1:l2;
            printf("Case %d:\n",t+1);
            printf("%s + %s = ",a,b);
            if(carry!=0)  printf("%d",carry);
            printf("%s\n",c);
            
        }
    }
    return 0;
}
#include<stdio.h>
#include<string.h>
int main()
{
    char a[1024],b[1024],c[1024];
    int n,t,l1,l2,l,i,j,carry,sum;
    while(EOF!=scanf("%d",&n))
    {
        for(t=0;t<n;t++)
        {
            if(t!=0)
                printf("\n");
            carry=0;
            memset(a,0,sizeof(a));
            memset(b,0,sizeof(b));
            memset(c,0,sizeof(c));
            scanf("%s%s",&a,&b);
            
            l1=strlen(a);l2=strlen(b);
            
            if(l1>l2)
            {    
                for(i=l1-1,j=l2-1;j>=0;i--,j--)
                {
                    sum=a[i]-'0'+b[j]-'0'+carry;//由字符串转换为数字——-‘0”
                    //这句还有个error,就是自动默认了i和j相等= =
                    c[i]='0'+sum%10;//由数字转换为字符串
                    carry=sum/10;
                }
                for(;i>=0;i--)//处理剩下一部分
                {
                    sum=a[i]-'0'+carry;
                    c[i]='0'+sum%10;
                    carry=sum/10;
                }
            }
            else
            {
                for(i=l1-1,j=l2-1;i>=0;i--,j--)
                {
                    sum=a[i]-'0'+b[j]-'0'+carry;
                    c[j]='0'+sum%10;
                    carry=sum/10;
                }
                for(;j>=0;j--)
                {
                    sum=b[j]-'0'+carry;
                    c[j]='0'+sum%10;//和上面的不太一样啊...
                    carry=sum/10;
                }
            }
            l=l1>l2?l1:l2;
            printf("Case %d:\n",t+1);
            printf("%s + %s = ",a,b);
            if(carry!=0)  printf("%d",carry);
            printf("%s\n",c);
            
        }
    }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是将代码转换为 C 语言形式的示例: ```c #include <stdio.h> #include <string.h> // 实现大数加法 char* add(char* x, char* y) { static char res[1000]; int carry = 0, i = strlen(x) - 1, j = strlen(y) - 1, k = 0; while (i >= 0 || j >= 0 || carry) { int sum = carry; if (i >= 0) sum += x[i--] - '0'; if (j >= 0) sum += y[j--] - '0'; carry = sum / 10; res[k++] = sum % 10 + '0'; } res[k] = '\0'; strrev(res); // 反转字符串 return res; } // 实现大数减法 char* subtract(char* x, char* y) { static char res[1000]; int borrow = 0, i = strlen(x) - 1, j = strlen(y) - 1, k = 0; while (i >= 0 || j >= 0) { int diff = borrow; if (i >= 0) diff += x[i--] - '0'; if (j >= 0) diff -= y[j--] - '0'; if (diff < 0) { diff += 10; borrow = -1; } else { borrow = 0; } res[k++] = diff + '0'; } res[k] = '\0'; strrev(res); // 反转字符串 return res; } int main() { char a[1000], b[1000]; printf("请输入两个无符号大数,以空格分隔:\n"); scanf("%s %s", a, b); char* sum = add(a, b); char* difference = subtract(a, b); printf("它们的和为:%s\n", sum); printf("它们的差为:%s\n", difference); return 0; } ``` 在 C 语言中,没有 `string` 类型,因此需要将其替换为 `char*` 类型,并使用 `strlen` 函数获取字符串长度。由于 C 语言中没有 `std` 命名空间,因此需要去除 `using namespace std;` 语句。另外,需要使用 `strrev` 函数反转字符串。 需要注意的是,在 C 语言中,需要手动为 `res` 数组添加结尾标记 `\0`,否则在输出时可能会出现意外结果。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值