更新了CocoaPod后变异出现的问题

原创 2016年08月30日 09:48:35

更新了CocoaPod后变异出现的问题

ld: embedded dylibs/frameworks are only supported on iOS 8.0 and later (@rpath/AFNetworking.framework/AFNetworking) for architecture arm64

这是第三方框架AFNetworking当前编辑的 Development Target是大于8.0的,而你的项目的 Development Target是小于8.0的,解决方案:

  1. 打开Pods项目
  2. 在Targets中找到AFNetworking
  3. 在General中找到Deployment Info
  4. 将Deployment Target 修改成 7.0
  5. 重新编译即可

相关文章推荐

新版 cocoapod安装、更新和使用 , 安装中出现的错误及解决方案

1.mac系统已经默认安装好Ruby环境,如果你不确定自己系统中是否有Ruby的,可以在终端中输入命令行:ruby -v查看当前ruby版本 如果ruby版本较低,可以通过rvm对Ruby进行...

CocoaPod更新第三方库列表是出现自动Merge出错怎么办

起因及现象: 深夜加班,准备把一个多月没用的CocoaPods神器祭出来。没想到悲催得碰到如下错误提示: [!] Pod::Executable pull Auto-merging geos/3...

mac CocoaPod安装常见问题以及解决方法

mac CocoaPod安装常见问题以及解决方法

安装CocoaPod遇到的问题

pod update/install时错误警告 错w

github中创建自己的cocoapod私有库_异常问题解决

1、file patterns: The `source_files` pattern did not match any file. 解决:检查你.podspec文件中s.source_files路...

关于CocoaPod安装常见问题

新拿到一台Mac装cocoapods,老是装不上,查找网上资料最终解决了下面总结下 CocoaPods的安装问题: 1.首先用淘宝的Ruby镜像来访问CocoaPods,打开终端输入以下命令: (1)...

【iOS学习笔记 16-7-20】mac os 10.11.4下cocoapod不能正常使用问题

电脑升级了最新的10.11.4,然后手机图新鲜升级了iOS10,所以要调试开发程序,自然xcode需要升级到最新的beta版,然后就是cocoapods出问题了。因为我是新买的mac,所以先安装coc...

CocoaPod的安装与问题处理

首先安装pods需要ruby环境支持,mac已经自带ruby,所以需要直接安装即可 1.     $  sudo gem install cocoapods 如果输入以后卡住很久不动,则输入以下命令(...

Cocoapod安装使用和常见问题

转自:http://www.th7.cn/Program/IOS/201503/408837.shtml 1.cocoapod的按照,cocoapod是运行在ruby环境下的,在ruby环境的 ,像c...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:更新了CocoaPod后变异出现的问题
举报原因:
原因补充:

(最多只允许输入30个字)