hdu 2035 人见人爱A^B (java)

问题:
此题需要用到大数来储存,但int还是能装下输入的n,m所以并没必要用BigInteger来装。
在开始用BigInteger装n时,即使将0转化成BigInteger型,用于判断0的if语句并没有效果,原因不明。




一些用于处理大数的函数:
Ⅰ基本函数:
1.valueOf(parament); 将参数转换为制定的类型
  比如 int a=3;
  BigInteger b=BigInteger.valueOf(a);
  则b=3;
  String s=”12345”;
  BigInteger c=BigInteger.valueOf(s);
  则c=12345;


2.add(); 大整数相加
BigInteger a=new BigInteger(“23”);
BigInteger b=new BigInteger(“34”);
a.      add(b);


3.subtract(); 相减
4.multiply(); 相乘
5.divide();    相除取整
6.remainder(); 取余
7.pow();   a.pow(b)=a^b
8.gcd();   最大公约数
9.abs(); 绝对值
10.negate(); 取反数
11.mod(); a.mod(b)=a%b=a.remainder(b);
12.max(); min();
13.punlic int comareTo();
14.boolean equals(); 是否相等
15.BigInteger构造函数:
一般用到以下两种:
BigInteger(String val);
将指定字符串转换为十进制表示形式;
BigInteger(String val,int radix);
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger
Ⅱ.基本常量:
A=BigInteger.ONE    1
B=BigInteger.TEN    10
C=BigInteger.ZERO   0
Ⅲ.基本操作
1.   读入:
用Scanner类定义对象进行控制台读入,Scanner类在java.util.*包中
Scanner cin=new Scanner(System.in);// 读入
while(cin.hasNext())   //等同于!=EOF
{
 int n;
 BigInteger m;
 n=cin.nextInt(); //读入一个int;
 m=cin.BigInteger();//读入一个BigInteger;
 System.out.print(m.toString());
}



人见人爱A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27559    Accepted Submission(s): 18833


Problem Description
求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”
 

Input
输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。
 

Output
对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。
 

Sample Input
  
  
2 3 12 6 6789 10000 0 0
 

Sample Output
  
  
8 984 1

代码:

import java.math.BigInteger;
import java.util.*;

public class Main{
	public static void main(String args[]){
		Scanner cin=new Scanner(System.in);
		while(cin.hasNext()){
			int n=cin.nextInt();
			int m=cin.nextInt();	
			if(n==0&&m==0){
				break;}
			else{
				BigInteger s;
				BigInteger k= BigInteger.valueOf(n);
				s= k.pow(m);
				BigInteger l=new BigInteger("1000");
				System.out.println(s.mod(l));
			}
		}
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值