POJ-1129 Channel Allocation 解题报告

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

A:BCDH 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

A: 

The repeaters are listed in alphabetical order. 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 


       题目链接:http://poj.org/problem?id=1129

       解法类型:四色图问题

       解题思路:这个题目暴力搜索也可以做出来,只是算法的效率很低。稍加转换一下就可以变成了四色图问题,即用n种颜色去涂地图,n<=4;这里可以看做最多有26种颜色,求最少的颜色数涂法。直接从每一点开始涂色就可以了,如果与当前发生冲突,则换一种颜色继续涂该点,否则当前点为该颜色。如此下去,直到全部涂色完。PS:这个算法的效率很高,status排名13,头一次这么靠前啊。。

       算法实现:

//STATUS:C++_AC_0MS_120K
#include<stdio.h>
#include<memory.h>
const int MAXN=27;
int search();
int is_ok(int line,int tar);
char map[MAXN],vis[MAXN][MAXN];
int n,min;
int main()
{
//	freopen("in.txt","r",stdin);
	int i,j;
	while(scanf("%d",&n)&&n)
	{
		min=0x80000000;
		memset(vis,0,sizeof(vis));

		for(i=0;i<n;i++){
			scanf("%s",map);
			for(j=0;map[j]!='\0';j++)
				if(map[j]!=':')vis[i][map[j]-'A']=1;
		}

    	search();

     	printf("%d ",min);
		printf("%s needed.\n",min==1?"channel":"channels");
	}
	return 0;
}

int search()
{
	int i,j,k;
	for(i=0;i<n;i++){    //依次给每一点涂色
		for(j=1;is_ok(i,j);j++);  //是否冲突
		if(j>min)min=j;    //是否为最小值
		for(k=0;k<n;k++)    //标记
			if(vis[k][i])vis[k][i]=j;
	}
	return 1;
}

int is_ok(int line,int tar)   //判断与前面的状态是否冲突
{
	int i,j;
	for(i=0;i<line;i++){
		if(vis[i][line]){
			if(line==i)
				for(j=0;j<line;j++){
					if(vis[i][j]==tar)return 1;  //冲突
				}
			else {
				if(vis[i][i]==tar)return 1;  //冲突
			}
		}
	}
	return 0; //不冲突
}

  • 3
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值