UVA 122 && HDU 1622 Trees on the level(构造二叉树+BFS层序遍历)

23 篇文章 0 订阅
12 篇文章 0 订阅

Trees on the level

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 783    Accepted Submission(s): 268


Problem Description
Trees are fundamental in many branches of computer science. Current state-of-the art parallel computers such as Thinking Machines' CM-5 are based on fat trees. Quad- and octal-trees are fundamental to many algorithms in computer graphics. 

This problem involves building and traversing binary trees. 
Given a sequence of binary trees, you are to write a program that prints a level-order traversal of each tree. In this problem each node of a binary tree contains a positive integer and all binary trees have have fewer than 256 nodes. 

In a level-order traversal of a tree, the data in all nodes at a given level are printed in left-to-right order and all nodes at level k are printed before all nodes at level k+1. 

For example, a level order traversal of the tree 


is: 5, 4, 8, 11, 13, 4, 7, 2, 1. 

In this problem a binary tree is specified by a sequence of pairs (n,s) where n is the value at the node whose path from the root is given by the string s. A path is given be a sequence of L's and R's where L indicates a left branch and R indicates a right branch. In the tree diagrammed above, the node containing 13 is specified by (13,RL), and the node containing 2 is specified by (2,LLR). The root node is specified by (5,) where the empty string indicates the path from the root to itself. A binary tree is considered to be completely specified if every node on all root-to-node paths in the tree is given a value exactly once. 

 

Input
The input is a sequence of binary trees specified as described above. Each tree in a sequence consists of several pairs (n,s) as described above separated by whitespace. The last entry in each tree is (). No whitespace appears between left and right parentheses. 

All nodes contain a positive integer. Every tree in the input will consist of at least one node and no more than 256 nodes. Input is terminated by end-of-file. 

 

Output
For each completely specified binary tree in the input file, the level order traversal of that tree should be printed. If a tree is not completely specified, i.e., some node in the tree is NOT given a value or a node is given a value more than once, then the string ``not complete'' should be printed
 

Sample Input
  
  
(11,LL) (7,LLL) (8,R) (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) () (3,L) (4,R) ()
 

Sample Output
  
  
5 4 8 11 13 4 7 2 1 not complete
 
UVa的一道题目
又做了一遍。
熟悉下二叉树。
题意:
根据输入的字符串建立二叉树,L向左走,R向右走,遇到()结束一组数据。
当某个结点被重复赋值时,是错误的,当某个结点未赋值就有左右孩子时,也是错误的!
当正确时输出 二叉树的层次遍历。
思路:
直接用结构体构造二叉树即可!
只是在结构体中多加了一个have_val表示是否被赋值过。
这个题目 又想起了一些知识,二叉树层序遍历可以用bfs队列来实现!
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
struct Node{
    int have_val;
    Node *left,*right;
    int v;
    Node():have_val(0),v(0),left(NULL),right(NULL){}
}*root;
vector<int >ans;
Node *newnode(){ return new Node(); }
bool ok = true;
void addnode(int v,char *s){
    int len = strlen(s);
    Node *u = root;
    for (int i = 0; i < len; ++i){
        if (s[i] == 'L'){
            if (u->left == NULL) u->left = newnode();
            u = u->left;
        }
        else if (s[i] == 'R'){
            if (u->right == NULL) u->right = newnode();
            u = u->right;
        }
    }
    if (u->have_val)ok=false;
    u->v= v;
    u->have_val = 1;
}
char s[105];
bool read_input(){
    ok = true;
    root = newnode();
    for (;;){
        if (scanf("%s",s) != 1)return false;
        if (!strcmp("()",s))return true;
        int v;
        sscanf(&s[1],"%d",&v);
        addnode(v,strchr(s,',')+1);
    }
}
queue<Node *>q;
void bfs(){
    while(!q.empty())q.pop();
    q.push(root);
    while(!q.empty()){
        Node *u = q.front();
        q.pop();
        if (!u->have_val){
            ok=false;
            return;
        }
        ans.push_back(u->v);
        if (u->left != NULL)q.push(u->left);
        if (u->right != NULL) q.push(u->right);
    }
}
int main(){
    while(read_input()){
        if (!ok){
            printf("not complete\n");
            continue;
        }
        ans.clear();
        bfs();
        if (!ok){
            printf("not complete\n");
            continue;
        }
        int len = ans.size();
        for (int i = 0; i < len ;++i){
            if (i)printf(" ");
            printf("%d",ans[i]);
        }
        printf("\n");
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值