win2000/XP下Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装

原创 2004年06月25日 20:10:00

Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

 

一、安装准备

在进行安装以前,你应该准备以下软件:

软件

版本

官方下载

备注

J2se

1.4.2_04

http://java.sun.com/j2se/1.4.2/download.html

 

Tomcat

5.0.19

http://www.apache.org/dist/jakarta/

 

Struts

1.1

http://www.apache.org/dist/jakarta/struts/

 

Eclipse

2.1.3

http://www.eclipse.org/downloads/index.php

目前eclipse最新版为eclipse3.0R1

EclipseLanguagePack

2.1.2.1

http://www.eclipse.org/downloads/index.php

该版本只能汉化eclipse2.1.3及以下版本

TomcatPlugin

2.2.1

http://www.sysdeo.com/eclipse/tomcatPlugin.html

该版本只适用于eclipse2.1.3及以下版本

Lomboz

2.1.3

http://www.objectlearn.com/index.jsp

该版本只适用于eclipse2.1.3及以下版本

EasyStruts

0.6.4

http://sourceforge.net/projects/easystruts

 

以上软件版本为安装成功的版本,为了使您的安装不至于出错请遵照以上版本准本软件。

 

二、JDK安装

1.安装J2SE-SDKE:/j2sdk1.4.2

       部分目录结构如下:

              E:/j2sdk1.4.2/bin

              E:/j2sdk1.4.2/lib

              E:/j2sdk1.4.2/jre

                     ...

2.配置环境变量如下:

JAVA_HOME = E:/j2sdk1.4.2

              PATH = %JAVA_HOME%/bin;.;%JAVA_HOME%/lib;%JAVA_HOME%/jre/lib;

              CLASSPATH = .;%JAVA_HOME%/lib;%JAVA_HOME%/jre/lib;

 

三、Tomcat安装

1.解压jakarta-tomcat-5.0.19.zipE:/tomcat

       部分目录结构如下:

              E:/tomcat/bin

              E:/tomcat/conf

              E:/tomcat/webapps

                     ...

2.配置环境变量如下:

TOMCAT_HOME = E:/tomcat

 

四、Struts安装

1.解压jakarta-struts-1.1.zipE:/jakarta-struts-1.1

       部分目录结构如下:

              E:/jakarta-struts-1.1/lib

              E:/jakarta-struts-1.1/webapps

                     ...

五、Eclipse安装

1.解压eclipse-SDK-2.1.3-win32.zipE:/eclipse213

       部分目录结构如下:

              E:/eclipse213/features

              E:/eclipse213/plugins

                     ...

2.启动Eclipse,看看安装是否成功

       如果启动不成功,请查看JRE是否安装

3.启动Eclipse,点击菜单 windows->preferences 在左边树中点击展开java,选择Installed JREs

如果Installed JREs如下则正确:

JRE Type

Name

Location

Standard VM

j2sdk1.4.2

E:/j2sdk1.4.2

 

六、Eclipse汉化

1.解压eclipse2.1.2.1-SDK-win32-LanguagePackFeature.zipE:/eclipse213

       将目录名eclipse2.1.2.1-SDK-win32-LanguagePackFeature改为eclipse2.1.2.1Language

部分目录结构如下:

              E:/eclipse213/eclipse2.1.2.1Language/eclipse/features

              E:/eclipse213/eclipse2.1.2.1Language/eclipse/plugins

                     ...

2.在E:/eclipse213下新建文件夹links,使得文件夹links和文件夹eclipse2.1.2.1Language同级

3.在E:/eclipse213/links下新建文件,文件名任取,这里我们命名为language.link,打开此文件,

加入 path = E://eclipse213//eclipse2.1.2.1Language

4.启动Eclipse,看看汉化是否成功,如不成功请检查language.link文件中配置信息path =

E://eclipse213//eclipse2.1.2.1Language和汉化文件夹eclipse2.1.2.1Language的安装路径是否一

 

七、TomcatPlugin安装

1.解压tomcatPluginV221.zip

2.将解压目录tomcatPluginV221下文件夹com.sysdeo.eclipse.tomcat_2.2.1复制到eclipse安装目

录中的plugins目录中,即E:/eclipse213/plugins

3.启动Eclipse

4.启动后你将看到你的菜单上多了一个下拉项Tomcat,快捷栏里多了三个Tomcat的猫图表,如

果没有看到,请点击 窗口->定制透视图,展开树结构中的“其它”,选择“Tomcat

5.点击 窗口->首选项

       在左边树中点击tomcat,设置tomcat versionversion 5.x

                                          设置tomcat versionversion 5.x

                                          设置tomcat-homeE:/tomcat

                                          设置perspective to switch when tomcat is startedjava

在左边树中点击tomcat->JVM setting,设置JREj2sdk1.4.2

点击应用确定

6.点击快捷按钮“Start Tomcat”来启动Tomcat

 

八、Lomboz安装

1.解压lomboz.213.zip

2.将解压目录lomboz.213/plugins下文件夹com.objectlearn.jdt.j2eecom.objectlearn.jdt.j2ee.editors

复制到eclipse安装目录中的plugins目录中,即E:/eclipse213/plugins

3.启动Eclipse

4.点击 窗口->首选项

       在左边树中点击lomboz,设置JDK tools.jar位置为E:/ j2sdk1.4.2/lib/tools.jar

在左边树中点击lomboz->server definitions,设置Server TypeApache Tomcat v5.0.x

                            设置Application Server DirectoryE:/tomcat

                            设置classpath Variable NameTOMCAT_HOME

                            设置classpath VariableE:/tomcat

点击应用确定

 

九、easyStruts安装

1.解压org.easystruts.eclipse_0.6.4.zip

2.将解压目录org.easystruts.eclipse_0.6.4下文件夹com.cross.easystruts.eclipse_0.6.4复制到eclipse

安装目录中的plugins目录中,即E:/eclipse213/plugins

3.启动Eclipse

4.点击 窗口->首选项

       在左边树中点击Easy Struts,选择struts1.1

ADD JREs如下:

struts.jar-E:/jakarta-struts-1.1/lib/struts.jar

ADD TLDs如下:

                     struts-tiles.tld-E:/jakarta-struts-1.1/lib/struts-tiles.tld

                     struts-template.tld-E:/jakarta-struts-1.1/lib/struts-template.tld

                     struts-nested.tld-E:/jakarta-struts-1.1/lib/struts-nested.tld

                     struts-logic.tld-E:/jakarta-struts-1.1/lib/struts-logic.tld

                     struts-html.tld-E:/jakarta-struts-1.1/lib/struts-html.tld

                     struts-bean.tld-E:/jakarta-struts-1.1/lib/struts-bean.tld

点击应用确定

win2000/XP下Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装

winXP下Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装   关键字:Eclipse、Tomcat、Struts、tomcatPlugin、Lomboz、...
  • JasonSeaver
  • JasonSeaver
  • 2004年06月25日 19:30
  • 2561

Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装

Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装发布日期:2004-08-11作者:arielxp 一、安装准备 在进行安装以前,你应该准备以下软件:  软件:...
  • JAVAvNET
  • JAVAvNET
  • 2004年09月17日 14:31
  • 637

winXP下Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装

我爱北京天安门 天安门上太阳升 伟大领袖毛主席 指引我们向前进 一、安装准备 在进行安装以前,你应该准备以下软件:  软件:J2se  版本...
  • arielxp
  • arielxp
  • 2004年07月14日 20:13
  • 9101

Eclipse主要插件Lomboz介绍

Eclipse主要插件Lomboz介绍Lomboz是Eclipse的一个主要的开源插件(open-source plug-in)...
  • lingzhao
  • lingzhao
  • 2007年07月15日 13:40
  • 928

jsp开发所需要的eclipse插件(lomboz、tomcatplugin)及其安装、配置方法

笔者近日准备在eclipse下进行jsp开发,在开发前对相关的插件安装和配置颇费了一番周折,网上也有许多初学者对此繁琐的过程有所抱怨,现在我把我的安装配置过程写出来,供大家参考。 一、系统环境配置1、...
  • ahuu
  • ahuu
  • 2006年05月24日 16:42
  • 42989

关于Eclipse4.7安装TomcatPlugin后无法显示三只猫问题

本人在给Ecllipse4.7Oxygen安装TomcatPlugin(尝试过TomcatPluginV33和V3.3.1)过程中,Eclipse的栏目中一直无法显示三只小猫,并且Preference...
  • Butterfly_resting
  • Butterfly_resting
  • 2017年08月31日 17:21
  • 1777

Eclipse中myeclipse和lomboz插件的应用

       最近学 Java web,发现需要在eclipse上配置一些插件。查了不少的相关资料,发现有时还挺不好搞,在这里把不是经验所的分享给大家。希望对喜欢eclipse刚开始学java web...
  • Silmon
  • Silmon
  • 2007年04月18日 18:02
  • 2769

Eclipse下Lomboz插件安装

1、下载时注意Eclipse和Lomboz版本号很重要      一般来说相同版本号的才比较兼容。      即:2.0的Eclipse对应插件就装2.0的Lomboz;Eclipse3.01...
  • largestone_187
  • largestone_187
  • 2010年07月20日 10:24
  • 7804

Eclipse下安装TomcatPlugin插件

在 Eclipse Kepler (4.3.1)下安装TomcatPlugin插件需要安装tomcatPluginV33.zip可以实现在Eclipse下要快速调试Web应用程序  TomcatP...
  • tc792617871
  • tc792617871
  • 2014年01月26日 00:11
  • 947

Ubuntu10.04 下配置Eclipse插件Tomcat

本文意在记录一个学习的过程。 一、环境 系统:Ubuntu10.04 开发工具:Eclipse3.5 插件:Apache Tomcat/7.026 二、Tomcat的下载及安装 ...
  • sonken_0824
  • sonken_0824
  • 2012年03月16日 11:54
  • 3224
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:win2000/XP下Eclipse与插件(tomcatPlugin Lomboz easyStruts)安装
举报原因:
原因补充:

(最多只允许输入30个字)