建枚举类时出现“Project '**' is not a J2SE 5.0 compliant project.”问题怎么办?

首先要确定是不是程序问题,如果不是程序问题,那可能是Eclipse设置有问题,而Eclipse可以指定编译深度,Eclipse设置默认值是1.4,可以将它改成5.0或者以上版本,方法是Window->...
  • pan_yeju
  • pan_yeju
  • 2015年10月06日 09:10
  • 1264

NetBeans IDE 5.5 J2SE(TM) Development Kit (JDK) 版本 5.0 下载

http://www.netbeans.org/kb/55/quickstart_zh_CN.htmlNetBeans IDE 5.5 快速入门指南欢迎使用 NetBeans IDE!本教程通过向您介...
  • laolaowhn
  • laolaowhn
  • 2008年01月15日 19:49
  • 2764

J2SE5.0学习所得

  1. 公共jre与jdk下的jre区别:Jdk下的jre bin中多了一个server,而公共jre的bin目录下面只有一个client. Server 与 Client选项的差别在于所使用的VM...
  • Daemon_neu
  • Daemon_neu
  • 2007年03月27日 19:53
  • 1067

Java使用eclipse新建枚举报出, 项目“xxxxx”不是符合 J2SE 5.0 的项目。的解决办法

在eclipse新建的枚举报出 项目“XXXX”不是符合 J2SE 5.0 的项目。这样的 错误,结果可能是编译器的版本的问题,也可能是你JDK版本的 问题。解决这个问题你可以按照如下的步骤来实现: ...
  • he_min
  • he_min
  • 2015年09月02日 20:44
  • 1291

Project 'Annotation' is not a J2SE 5.0 compliant project.

Project 'Annotation' is not a J2SE 5.0 compliant project. 解决方法1:https://www.genuitec.com/forums/top...
  • KrystalBm
  • KrystalBm
  • 2016年11月17日 15:43
  • 517

[J2SE 5.0专题]虚拟机

随着J2SE 5.0的发布,JavaTM HotSpot虚拟机也随之更新。新的变化包括:类数据共享、垃圾收集、服务器级机器侦测、线程优先级变化、致命错误处理、高精度计时支持等。接下来我们大家一起来一个...
  • leek2000
  • leek2000
  • 2005年04月05日 09:02
  • 1905

J2SE 5.0实例---枚举

枚举在过去,我们必须用整型常数代替枚举,随着J2SE 5.0的发布,这样的方法终于一去不复返了。一个简单的枚举类型定义如下:public enum Weather{       SUNNY,RAINY...
  • jayliu
  • jayliu
  • 2005年03月18日 12:48
  • 1414

J2SE 5.0泛型

  J2SE 5.0引入了许多新型的集合API-你需要了解它们以便能够正确地实现泛型定制的集合-它可以无缝地与多种类型和新型的"for each"结构一起工作。本文将向你展示示怎样创建与J2SE最新特...
  • liumm1983
  • liumm1983
  • 2007年03月19日 14:20
  • 495

J2SE 5.0新特性

J2SE 5.0新特性 http://whitfox.woku.com/article/789795.html
  • kzjay
  • kzjay
  • 2010年01月04日 00:14
  • 348

[J2SE 5.0专题]注解

注解(Annotations)在我看来是J2SE 5.0中比较重大的新特性。将来的EJB 3.0规范将会全面利用该特性来简化Session Bean、 Message-Driven Bean和Enti...
  • leek2000
  • leek2000
  • 2005年04月05日 09:02
  • 2253
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:j2se 5.0
举报原因:
原因补充:

(最多只允许输入30个字)