HDU 2795 Billboard //线段树简单应用

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10074    Accepted Submission(s): 4482


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1698  1166  1542  1828  1540 
#include <stdio.h>

struct node
{
    int l, r;
    int max;
}tree[600000];

int MAX(int a, int b)
{
    if(a>b)
        return a;
    return b;
}
void build(int l, int r, int n, int a)
{
    int mid;
    tree[n].l=l, tree[n].r=r;
    if(l==r)
    {
        tree[n].max = a;
        return ;
    }
    mid = (tree[n].l + tree[n].r)>>1;
    build(l, mid, 2*n, a);
    build(mid+1, r, 2*n+1, a);

    tree[n].max = a;
}
void update(int n)
{
    int k;

    k = n/2;
    while(k)
    {
        tree[k].max = MAX(tree[k*2].max, tree[k*2+1].max);
        k = k/2;
    }
    return;
}
int add(int n, int a, int k)
{
    if(tree[n].max >= a && tree[n].l <= k)
    {
        if(tree[n].l == tree[n].r)
        {
            tree[n].max -= a;
            update(n);
            return tree[n].l;
        }
        if(tree[n*2].max >= a)
            add(2*n, a, k);
        else
            add(2*n+1, a, k);
    }
    else
        return -1;
}

int main()
{
    int h, w, n;
    int i;
    int aw;
    
    while(scanf("%d%d%d", &h, &w, &n)!=-1)
    {
        build(1, n, 1, w);
        for(i=0; i<n; i++)
        {
            scanf("%d", &aw);

            printf("%d\n", add(1, aw, h));
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值