sdutacm-数据结构实验之链表四:有序链表的归并

数据结构实验之链表四:有序链表的归并

TimeLimit: 1000MS Memory Limit: 65536KB

SubmitStatistic

ProblemDescription

分别输入两个有序的整数序列(分别包含MN个数据),建立两个有序的单链表,将这两个有序单链表合并成为一个大的有序单链表,并依次输出合并后的单链表数据。

Input

第一行输入MN的值;
第二行依次输入M个有序的整数;
第三行依次输入N个有序的整数。

Output

输出合并后的单链表所包含的M+N个有序的整数。

ExampleInput

65

123 26 45 66 99

1421 28 50 100

ExampleOutput

114 21 23 26 28 45 50 66 99 100

Hint

不得使用数组!

Author

D
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<stack>
#include<queue>
//#include<dqeue>
struct node
{

  int data;
  struct node*next;

};
struct  node*creat(struct node*head,int n)
{
      head= (struct node*)malloc(sizeof(struct node));
      head->next =NULL;

      struct node*tail = head;
      for(int i=1;i<=n;i++)
      {
          struct node*p = (struct node*)malloc(sizeof(struct node));
          p->next =NULL;
         scanf("%d",&p->data);
         tail->next = p;
         tail = p;

      }

      return head;



}
struct node*guibing(struct node*head1,struct node*head2)
{

    head1= head1->next;
    head2 =head2->next;
    struct node*tail,*p,*mail;
    tail = (struct node*)malloc(sizeof(struct node));
    mail =  tail;
    while(head1&&head2)
    {

        if(head1->data<head2->data)
        {
           mail->next = head1;
           mail = head1;
           p = head1;
           head1 = head1->next;
           p->next =NULL;
        }
        else
        {

          mail->next =head2;
          mail = head2;
          p = head2;
          head2 = head2->next;
          p->next =NULL;




        }
        }
        if(head1)
        {

            while(head1)
            {
                mail->next =head1;
                mail = head1;
                p = head1;
                head1 = head1->next;
                p->next = NULL;

            }
        }
        else if(head2)
        {
          while(head2)
          {
             mail->next =head2;
             mail = head2;
             p = head2;
             head2 = head2->next;
             p->next =NULL;


          }




        }





    return tail;

}
void show(struct node*head)
{
     struct node*tail;
     tail =head;
     int top = 1;
     while(tail->next)
     {

           if(top)top=0;
           else printf(" ");
           printf("%d",tail->next->data);
           tail = tail->next;

     }





}
int main()
{

     int n,m;
    scanf("%d%d",&n,&m);


        struct node*head1= (struct node*)malloc(sizeof(struct node));
        struct node*head2 = (struct node*)malloc(sizeof(struct node));
        head1 = creat(head1,n);
        head2= creat(head2,m);
        head1 = guibing(head1,head2);
        show(head1);



   return 0;
}


/***************************************************
User name: jk160505徐红博
Result: Accepted
Take time: 0ms
Take Memory: 152KB
Submit time: 2017-01-14 17:07:39
****************************************************/


 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值