PAT_1024: Palindromic Number

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
备注:简单题,由于N可能会很大,加法都用字符串形式搞定。
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

bool IsPalindromic(char s[])
{
	for(int i=0,j=strlen(s)-1;i<=j;i++,j--)
		if(s[i]!=s[j])
			return false;
	return true;
}

void reverse(char s[])
{
	for(int i=0,j=strlen(s)-1;i<=j;i++,j--)
	{
		char c;
		c = s[i];
		s[i] = s[j];
		s[j] = c;
	}
}

void AddNums(char a[],char b[],char res[])
{
	int carry = 0, j = 0;
	for(int i=strlen(a)-1;i>=0;i--)
	{
		int sum = a[i]-'0'+b[i]-'0' + carry;
		carry = sum/10;
		int digit = sum%10;
		res[j++] = digit+'0';
		if(i==0 && carry>0)
			res[j++] = carry+'0';
	}
	res[j++]= '\0';
	reverse(res);
}

int main()
{
	int k,i=0;
	char snum[100],revnum[100],res[100];
	scanf("%s %d",snum,&k);

	strcpy(revnum,snum);
	if(IsPalindromic(snum))
	{
		printf("%s\n",snum);
		printf("0\n");
		return 0;
	}

	while(i<k)
	{
		reverse(revnum);
		// 加法重写,用字符串
		AddNums(snum,revnum,res);
		
		if(IsPalindromic(res))
		{
			printf("%s\n",res);
			printf("%d\n",i+1);
			return 0;
		}
		strcpy(snum,res);
		strcpy(revnum,res);
		i++;
	}
	printf("%s\n",snum);
	printf("%d\n",k);


	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值