【树状数组--dfs序转化】poj3321 Apple Tree

Apple Tree
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29822 Accepted: 8881

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

题意:一棵苹果树,每个树杈可以长一个苹果,kaka可以摘掉,苹果树也可以在空的树杈在长出一个;输入n表示有n个树杈,接下来n-1行,每行表示有u号树杈与v号树杈相连;有两种操作,一种是Q询问树杈x的子树总过有多少个苹果,另一种是C改变树杈x的苹果状态;

思路:先用dfs序变树结构为一个序列,然后操作序列求结果;关键是了解dfs序:点击打开链接

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;

const int maxn=110000;
int A[maxn],C[maxn],N,M;
int L[maxn],R[maxn],tot;

typedef vector<int> INT;  //不改成这样是会超时的,奇妙
vector<INT>E(maxn);

int lowbit(int k)
{
    return k&(-k);
}

void add(int x,int d)
{
    while(x<=N)
    {
        C[x]+=d;
        x+=lowbit(x);
    }
}

int sum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=C[x];
        x-=lowbit(x);
    }
    return res;
}

void dfs(int x,int pre)                 //dfs序;
{
    L[x]=++tot;
    for(int i=0;i<(int)E[x].size();i++)
    {
        int y=E[x][i];
        if(y==pre) continue;
        dfs(y,x);
    }
    R[x]=tot;
}

int main()
{
    scanf("%d",&N);
    for(int i=1;i<N;i++)
    {
        int u,v;
        scanf("%d%d",&u,&v);
        E[u].push_back(v);             //STL模拟邻接表;
    }

    for(int i=1;i<=N;i++)
    {
        A[i]=1;
        add(i,1);
    }
    dfs(1,0);                          

    scanf("%d",&M);
    while(M--)
    {
        char s[10];
        int num;
        scanf("%s",s);
        if(s[0]=='Q')
        {
            scanf("%d",&num);
            printf("%d\n",sum(R[num])-sum(L[num]-1));
        }
        else
        {
            scanf("%d",&num);
            if(A[L[num]])
            {
                A[L[num]]=0;
                add(L[num],-1);
            }
            else
            {
                A[L[num]]=1;
                add(L[num],1);
            }
        }
    }
    return 0;
}

dfs 序把树状结构便为一个序列,就可以很方便的使用树状数组解决问题了;

vector 模拟邻接表用时会比链表模拟链表长,本题一直TLE直到把vector<int>E[maxn]改成typedeg vector<int>INT ; vector<INT>E(maxn);

所以要学习一波链表模拟邻接表了~



深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理列数据,如时间列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值