阿里云centos7安装yii框架

原创 2017年06月20日 01:35:17

1.主要安装过程没什么可说的,直接按照官网(http://www.yiiframework.com/download/ ,或者中文站 http://www.yiichina.com/download)进行,主要分为以下 several steps:

step one : 安装composer:
参考:https://getcomposer.org/download/
依次在终端执行以下四个命令

命令1. php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');"
命令2. php -r "if (hash_file('SHA384', 'composer-setup.php') === '669656bab3166a7aff8a7506b8cb2d1c292f042046c5a994c43155c0be6190fa0355160742ab2e1c88d40d5be660b410') { echo 'Installer verified'; } else { echo 'Installer corrupt'; unlink('composer-setup.php'); } echo PHP_EOL;"
命令3. php composer-setup.php
命令4. php -r "unlink('composer-setup.php');"

以上就是安装composer的步骤,另外,我是在/usr/local/bin/下面执行的这些语句

step 吐:安装composer asset插件
执行命令:
php composer.phar global require “fxp/composer-asset-plugin:^1.2.0”

注意:这个时候好像在当前文件夹下已经下载了composer.phar文件

step three:安装基本款yii
这是最重要的一步,这里卡了半天,好几个地方会出错:
执行命令:
php composer.phar create-project yiisoft/yii2-app-basic basic 2.0.12
1)如果不报错,就没问题
2)如果composer.phar 改成了composer,的上述命令记得替换为php composer createXXX
3)可能会报错,比如:
这里写图片描述
[Composer\Repository\InvalidRepositoryException]
No valid bower.json was found in any branch or tag of https://github.com/jquery/jquery-dist.git, could not load a package from it
说是没有合法bower.json文件什么的
或者

或者
[InvalidArgumentException]
Project directory basic/ is not empty.

试了好多方法,还是不成功,比如把https换成http什么的
最后注意到,很多网上的解决方案好像是要编辑一个composer.json文件,而我的文件夹里面没有,再者,从第一张图里面的那个链接:https://github.com/jquery/jquery-dist.git
可看到有个bower.json文件,打开此文件,将里面的内容:

{
“name”: “jquery”,
“main”: “dist/jquery.js”,
“license”: “MIT”,
“ignore”: [
“package.json”
],
“keywords”: [
“jquery”,
“javascript”,
“browser”,
“library”
]
}

存到 composer.json文件里(新建一个)

最后,再次执行基本款的安装命令:
php composer.phar create-project yiisoft/yii2-app-basic basic 2.0.12
大功告成
这里写图片描述

在centos部署yii2 advanced框架

手头闲置了一个阿里云的云服务器,干脆拿来部署一个yii2 advance框架,之后也可以在上面搭建自己的个人博客。话不多说,撸起袖子开干。 本次部署需要达到的目标: a、可访问的网站正式环境端口1...
  • Jarvis_kang
  • Jarvis_kang
  • 2017年03月06日 17:56
  • 1579

YII2.0.7 advanced 安装使用记录一

环境:centos+lnmp+composer 代码目录:/home/wwwroot,以下未做声明的,都是在此路径下操作 一、安装篇 采用composer安装,先装扩展 composer ...
  • dl425134845
  • dl425134845
  • 2016年03月03日 11:19
  • 780

yii composer安装 github授权问题

因为composer的很多包的获取途径是通过github,而部分获取是需要授权码的安装中间会提示你输入github的tokentoken的获取进入 https://github.com/setting...
  • u011088792
  • u011088792
  • 2017年10月23日 10:45
  • 151

Linux使用Composer安装yii2的方法及bug处理

Linux使用Composer安装yii2的方法及bug处理 这里只讲linux下安装Yii2的方法,windows安装yii2 的方法 请参见我的另一篇博文 http://bl...
  • u010412301
  • u010412301
  • 2017年02月18日 22:58
  • 857

No valid bower.json was found in any branch ...

Question:[Composer\Repository\InvalidRepositoryException] No valid bower.json was found in any bra...
  • joeson7456
  • joeson7456
  • 2017年09月10日 16:30
  • 364

Mac OS安装gem rmagick

首先,必须安装ImageMagic
  • rocLv
  • rocLv
  • 2014年06月07日 11:18
  • 1696

jHipster 3.4 创建最流行Java Web应用项目最简单的入门基本教程

转自:http://www.cnblogs.com/sam8881-Blogs/p/5630976.html 学习(Java Web)编程技术要点及方向; 完成项目的要决 jHipster...
  • he90227
  • he90227
  • 2016年10月09日 11:10
  • 5480

linux centos 下安装yii

1.下载yii 压缩包 可以到 官网 www.yiifram
  • KIKI_Q
  • KIKI_Q
  • 2014年08月27日 17:53
  • 511

centos 7 epel源 安装jq

一、简介 EPEL是企业版 Linux 附加软件包的简称,EPEL是一个由Fedora特别兴趣小组创建、维护并管理的,针对 红帽企业版 Linux(RHEL)及其衍生发行版(比如 CentOS、...
  • shashayangzhou
  • shashayangzhou
  • 2016年10月30日 20:56
  • 2196
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:阿里云centos7安装yii框架
举报原因:
原因补充:

(最多只允许输入30个字)