(线段树功能:update:成段替换 query:简单hash)Mayor's posters

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 39558 Accepted: 11479

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source


!!注意:以C++提交则AC, 以G++提交则RE. 暂时没弄懂是怎么回事, 希望有知道的人告诉我, 感谢不已:) 
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l , m , rt << 1
#define rson m + 1 , r , rt << 1 | 1

const int maxn = 11111;
bool hash[maxn];
int li[maxn], ri[maxn];
int X[maxn * 3];
int col[maxn << 4];
int cnt;
/*PushDown的功能是:标记传递(此题标记为poster的编号)*/
void PushDown(int rt) {
	if (col[rt] != -1) {
		col[rt << 1] = col[rt << 1 | 1] = col[rt];
		col[rt] = -1;
	}
}
/*update的功能是:用col[]实现"贴poster"*/
void update(int L, int R, int c, int l, int r, int rt) {
	if (L <= l && r <= R) {
		col[rt] = c;
		return;
	}
	PushDown(rt);
	int m = (l + r) >> 1;
	if (L <= m) update(L, R, c, lson);
	if (m < R) update(L, R, c, rson);
}
void query(int l, int r, int rt) {
	if (col[rt] != -1) {
		if (!hash[col[rt]]) cnt++;		//hash[]标记编号为col[rt]的poster是否已计数
		hash[col[rt]] = true;
		return;
	}
	if (l == r) return;
	int m = (l + r) >> 1;
	query(lson);
	query(rson);
}
/*Bin()的功能是:端点映射*/
/*利用二分查找将大数化成小数 (区间左右端点"映射"!!到X[]中对应的下标值)*/
int Bin(int key, int n, int X[]) {
	int l = 0, r = n - 1;
	while (l <= r) {
		int m = (l + r) >> 1;
		if (X[m] == key) return m;
		if (X[m] < key) l = m + 1;
		else r = m - 1;
	}
	return -1;
}
int main() {
	int T, n;
	scanf("%d", &T);
	while (T--) {
		scanf("%d", &n);
		int nn = 0;
		for (int i = 0; i < n; i++) {
			scanf("%d%d", &li[i], &ri[i]);
			X[nn++] = li[i];
			X[nn++] = ri[i];
		}
		//无重复地采集区间的左右端点
		sort(X, X + nn);
		int m = 1;
		for (int i = 1; i < nn; i++) {
			if (X[i] != X[i - 1]) X[m++] = X[i];
		}//

		//在非相邻点之间再插入一点,使得非相邻点之间的距离在离散化后仍然存在
		//此题中区间端点代表单位长度,若它仅代表一个点,则次步可省略
		for (int i = m - 1; i > 0; i--) {
			if (X[i] != X[i - 1] + 1) X[m++] = X[i - 1] + 1;
		}
		sort(X, X + m);//

		/*利用二分查找将大数化成小数 (区间左右端点"映射"!!到X[]中对应的下标值)*/
		memset(col, -1, sizeof(col));
		for (int i = 0; i < n; i++) {
			int l = Bin(li[i], m, X);
			int r = Bin(ri[i], m, X);
			update(l, r, i, 0, m - 1, 1);
		}//

		cnt = 0;
		memset(hash, false, sizeof(hash));
		query(0, m - 1, 1);
		printf("%d\n", cnt);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值