PAT 1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路:题目有点长,主要要求是输入书本的相关信息,然后输入5种索引方式在这些书本信息中寻找匹配的结果。

 
#include<iostream>
#include<string>
#include<sstream>
#include<vector>
#include<algorithm>

using namespace std;

struct book { //书的信息
	string id;
	string name;
	string ath;
	vector<string> key;
	string pub;
	string time;
};   

int main()
{
	int n, m;
	string s, st;
	cin >> n;
	vector<book> b(n);
	for (int i=0; i!=n; ++i) { //输入书的信息
		cin >> b[i].id;
		cin.ignore();
		getline(cin, b[i].name);
		getline(cin, b[i].ath);
		getline(cin, s);
		istringstream is(s); //拆分字符串成为单独的关键字
		while (is >> s) 
			b[i].key.push_back(s);
		getline(cin, b[i].pub);
		cin >> b[i].time;
	}
	cin >> m;
	cin.ignore(); //在cin后用getline需要用,不然getline读入空行
	while(m--) {
		string s, st;
		vector<string> v;
		getline(cin, s);
		cout << s << endl;
		st.assign(s.begin()+3, s.end()); //索引内容
		for (int i=0; i!=n; ++i)  //按索引寻找书本匹配项
			if (st == b[i].name || st== b[i].ath || st==b[i].pub 
				|| st == b[i].time ||find(b[i].key.begin(), b[i].key.end(), st) != b[i].key.end() )
				v.push_back(b[i].id);

		sort (v.begin(), v.end()); //结果按id排序
		if (v.empty())
			cout << "Not Found" << endl;
		else
			for (int j=0; j!=v.size(); ++j)
				cout << v[j] << endl;
	}
	system("pause");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值