Unable to find valid certification path to requested target

原创 2015年11月19日 10:18:44


 

处理方法1:

在用户目录下找到隐藏文件夹.gradle,在该目录下找到文件gradle.properties(默认不存在,需要手动创建),将下面内容写入文件中

<!-- lang: shell -->
systemProp.http.proxyHost=www.proxyhost.org
systemProp.http.proxyPort=8080
systemProp.http.proxyUser=userid
systemProp.http.proxyPassword=password
systemProp.http.nonProxyHosts=*.nonproxyrepos.com|localhost

systemProp.https.proxyHost=www.proxyhost.org
systemProp.https.proxyPort=8080
systemProp.https.proxyUser=userid
systemProp.https.proxyPassword=password
systemProp.https.nonProxyHosts=*.nonproxyrepos.com|localhost

处理方法2 :我的问题是:没找到gradle路径,我的解决方法是:windows--->preferences-->gradle--->folder-->填写地址(gradle的安装路径)我的是E:/tools/gradle

如下图:

      希望对大家 有用



   


版权声明:本文为博主原创文章,未经博主允许不得转载。

1:java的jdk导入需要的证书就解决了,2:写个方法,在连接之前免验证证书【比较难解决】

12
  • shenhonglei1234
  • shenhonglei1234
  • 2017年06月08日 15:29
  • 207

解决Jenkins邮箱配置中,使用SSL连接的问题

背景:最近在配置Jenkins的邮件发送功能时,正确设置好各参数后,在进行通过发送测试邮件测试配置时,总是出现unable to find valid certification path to re...
  • jiang1986829
  • jiang1986829
  • 2016年03月22日 15:11
  • 5780

Java安全通信:HTTPS与SSL

1. HTTPS概念         1)简介            HTTPS(全称:Hypertext Transfer Protocol over Secure Socket Layer),...
  • z69183787
  • z69183787
  • 2013年12月26日 12:31
  • 1950

Mule ESB浅析2——源码编译与安装

Mule ESB浅析2——源码编译与安装   基于源码进行编译 1,从svn获取代码之后,命令行下进入到对应目录执行如下指令: mvn –DskipTests install   此处mv...
  • chengzhezhijian
  • chengzhezhijian
  • 2015年04月28日 11:13
  • 665

一步一步调通Openfire3.10.2+smack4.1.4官方示例代码

一步一步调通Openfire3.10.2+smack4.1.4官方示例代码 首先在电脑上安装Openfire服务器(本文安装的版本为Openfire 3.10.2) Openfire下载地址htt...
  • frankcheng5143
  • frankcheng5143
  • 2015年09月21日 10:04
  • 3953

导入Fiddler的证书到Java中的cacerts证书库

有时需要使用Fiddler来监控http请求,但是http请求需要证书,要让Fiddler来监控http请求,在Java代码中需要设置代理,设置后如果没有添加Fiddler的FiddlerRoot.c...
  • wang704987562
  • wang704987562
  • 2017年01月19日 18:00
  • 847

日志实时分析平台ELK部署(+shield安全组件)

安装ELK elasticsearch,logstash,kibana三个组件,直接下载rpm文件安装即可 Logstash ogstash的配置在正文中已经展示了我们现在87上的配置文件了。 ...
  • pujiaolin
  • pujiaolin
  • 2016年08月05日 16:05
  • 1284

cocoapod不能使用的解决办法

如图:升级Xcode7.1之后,之前安装的cocoapod不能使用了,报错如下。 文字描述为: [!] /usr/bin/git clone ‘https://github.com/C...
  • u013822374
  • u013822374
  • 2015年10月25日 17:08
  • 2217

> 软件编程 > 安卓开发 > Unity编译时找不到AndroidSDK的问题:Unable to list target pla

http://www.qingpingshan.com/rjbc/az/228769.html 现象 在用 Unity 编译 Android 平台的应用时,遇到 Unable to l...
  • OnafioO
  • OnafioO
  • 2017年05月19日 17:20
  • 3878

Java访问不受信任证书的https网站

如果在Java中访问不受信任证书的https网站,会出现如下错误: javax.net.ssl.SSLHandshakeException: sun.security.validator.V...
  • nonths
  • nonths
  • 2014年06月11日 10:32
  • 1450
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Unable to find valid certification path to requested target
举报原因:
原因补充:

(最多只允许输入30个字)