关闭

git clone templates not found / Unable to find remote helper for 'https' 错误

347人阅读 评论(0) 收藏 举报
分类:

ubuntu服务器,执行 git  clone https://github.com/xxx/xxx.git 出现git clone templates not found / Unable to find remote helper for 'https'  错误。但是用超级用户执行git clone 命令没有问题。

在普通用户下查看git版本git --version 显示git version 1.9.4;在超级用户显示git version 2.1.4;

系统中有两个不同版本的git!

原来以前在服务器上安装了ti-am335x的SDK,这个SDK中包含有一个版本的git,并在.bashrc中添加了环境变量。卸载其中一个git问题就可以解决。


参考:https://github.com/cmderdev/cmder/issues/144


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:682次
    • 积分:28
    • 等级:
    • 排名:千里之外
    • 原创:2篇
    • 转载:0篇
    • 译文:0篇
    • 评论:2条
    文章分类
    文章存档
    最新评论
  • 宏定义

    dfgrgf: @ycr15:我是在跑freescale 的板子时遇到的,它的库中有用到##;这样做可以防止宏的递归...

  • 宏定义

    ycr15: 小白,这样子有意义么?