poj Flip Game(DFS)(枚举)

46 篇文章 0 订阅
15 篇文章 0 订阅
Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

思路:DFS枚举所有情况,因为每个棋子只有黑或白两种情况,所以总共有2^16种情况
代码:
#include<stdio.h>
int map[5][5];
int flag,step;

void flip(int i,int j)//翻转
{
    map[i][j]=!map[i][j];
    if(i<3)
        map[i+1][j]=!map[i+1][j];
    if(j<3)
        map[i][j+1]=!map[i][j+1];
    if(i>0)
        map[i-1][j]=!map[i-1][j];
    if(j>0)
        map[i][j-1]=!map[i][j-1];
}

int check()//检测是否“清一色”
{
    for(int i=0; i<4; i++)
        for(int j=0; j<4; j++)
            if(map[i][j]!=map[0][0])
                return 0;
    return 1;
}

void dfs(int i,int j,int dp)
{
    if(dp==step)
    {
        flag=check();
        return ;
    }
    if(flag||i==4)
        return ;
    flip(i,j);//此位置翻转
    if(j<3)
        dfs(i,j+1,dp+1);
    else
        dfs(i+1,0,dp+1);
    flip(i,j);//回溯恢复成翻转前的状态
    if(j<3)//此位置不翻转
        dfs(i,j+1,dp);
    else
        dfs(i+1,0,dp);
}

int main()
{
    int i,j;
    char s;
    for(i=0; i<4; i++)
    {
        for(j=0; j<4; j++)
        {
            scanf("%c",&s);
            if(s=='b')//将图案转换成01图
                map[i][j]=1;
            else
                map[i][j]=0;
        }
        getchar();
    }
    flag=0;
    for(step=0; step<=16; step++)//枚举所有情况,因为总共只有16个格子,所以最多只能进行16步
    {
        dfs(0,0,0);
        if(flag)
            break;
    }
    if(flag)
        printf("%d\n",step);
    else
        printf("Impossible\n");
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值