poj Supermarket(贪心)(并查集)(优先队列)

31 篇文章 0 订阅
20 篇文章 0 订阅
Supermarket

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σ x∈Sellpx. An optimal selling schedule is a schedule with a maximum profit. 
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80. 

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products. 

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


思路1:按利润从大到小排序,然后从最大的利润开始,如果这一天没被占用就将其利润加入sum,并将其售卖的时间标记为1,表示这一天已占用

代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 10000+10
struct node
{
    int x,y;
} p[maxn];
int vis[maxn];

bool cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x>b.x;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        sort(p,p+n,cmp);
        int sum=0;
        for(int i=0; i<n; i++)
        {
            for(int j=p[i].y; j>0; j--)
            {
                if(!vis[j])
                {
                    sum+=p[i].x;
                    vis[j]=1;
                    break;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

思路2:思路1的改进版,用并查集将时间加入集合中,先令pre[dx]=dx,如果这一天要被占用就将其pre[dx]改为pre[dx]=dx-1,表示日期和dx相同的物品最晚只能从dx-1天售卖

代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

#define maxn 10000+10
struct node
{
    int px,dx;
    friend bool operator<(node a,node b)
    {
        return a.px>b.px;
    }
}q[maxn];
int pre[maxn];

void init(int n)
{
    for(int i=0;i<=n;i++)
        pre[i]=i;
}

int Find(int x)
{
    int temp=pre[x];
    if(x==pre[x])
        return x;
    pre[x]=Find(temp);
    return pre[x];
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int maxx=0,i;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&q[i].px,&q[i].dx);
            if(q[i].dx>maxx)
                maxx=q[i].dx;
        }
        init(maxx);
        sort(q,q+n);
        int sum=0;
        for(i=0;i<n;i++)
        {
            int k=Find(q[i].dx);
            if(k>0)
            {
                sum+=q[i].px;
                pre[k]=k-1;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

思路3:先将其按时间从大到小排序,然后从最大时间开始贪心,先将满足时间的加入优先队列,再用优先队列让同一日期的物品利润最大的出来计算入和,队列中的其他物品并入到下一天的计算,最后直到队列为空或者已经全部计算结束

代码:
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

#define maxn 10000+10
struct node
{
    int px,dx;
    friend bool operator<(node a,node b)
    {
        return a.px<b.px;
    }
}q[maxn];

bool cmp(node a,node b)
{
    return a.dx>b.dx;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&q[i].px,&q[i].dx);
            if(q[i].dx>maxx)
                maxx=q[i].dx;
        }
        sort(q,q+n,cmp);
        priority_queue<node>w;
        int ps=0,sum=0;
        for(int i=maxx;i>0;i--)
        {
            while(ps<n&&q[ps].dx>=i)
                w.push(q[ps++]);
            if(!w.empty())
            {
                sum+=w.top().px;
                w.pop();
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 4
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值