hdu4725——The Shortest Path in Nya Graph(SPFA+两层图)

Problem Description
This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on.
The Nya graph is an undirected graph with “layers”. Each node in the graph belongs to a layer, there are N nodes in total.
You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost.
Besides, there are M extra edges, each connecting a pair of node u and v, with cost w.
Help us calculate the shortest path from node 1 to node N.

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has three numbers N, M (0 <= N, M <= 105) and C(1 <= C <= 103), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers.
The second line has N numbers li (1 <= li <= N), which is the layer of ith node belong to.
Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 104), which means there is an extra edge, connecting a pair of node u and v, with cost w.

Output
For test case X, output “Case #X: ” first, then output the minimum cost moving from node 1 to node N.
If there are no solutions, output -1.

Sample Input
2
3 3 3
1 3 2
1 2 1
2 3 1
1 3 3

3 3 3
1 3 2
1 2 2
2 3 2
1 3 4

Sample Output
Case #1: 2
Case #2: 3

挺有意思的最短路
题意是在无向图中,每个节点还属于一个层(layer),可以从第i个层的节点移动到第i+1个层的节点,花费是c。然后是给出一个普通的无向图,求1到n的最短路。
因为有层的存在,在寻找最短路的时候可能直接经过层,不妨把层也当做节点,层与所属节点之间的花费是0,表示随时可以从层转移到节点上寻找最短路,然后层与层之间的花费是c,节点到下一层或上一层的的花费也是c,节点与节点之间的花费是w,方便起见,层的节点编号从n+1到n+n。
另外数组开大点,不然会TLE,我很奇怪为什么不是RE,害得我判断失误

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 200010
#define Mod 10001
using namespace std;
struct Edge
{
    int v,w,next;
};
Edge edge[MAXN*20];
int head[MAXN],n,m,e,vis[MAXN],dis[MAXN];
void add(Edge *edge,int *head,int u,int v,int w)
{
    edge[e].v=v;
    edge[e].w=w;
    edge[e].next=head[u];
    head[u]=e;
    e++;
}
void spfa(Edge *edge,int *head,int u)
{
    memset(vis,0,sizeof(vis));
    for(int i=1; i<=2*n; ++i) //这里WA了
        dis[i]=INF;
    dis[u]=0;
    queue<int> q;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            int v=edge[i].v,w=edge[i].w;
            if(w+dis[u]<dis[v])
            {
                dis[v]=w+dis[u];
                if(!vis[v])
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
}
int layer[MAXN];
int main()
{
    int t,c,u,v,w;
    scanf("%d",&t);
    for(int cnt=1; cnt<=t; ++cnt)
    {
        e=0;
        scanf("%d%d%d",&n,&m,&c);
        memset(vis,0,sizeof(vis));
        memset(head,-1,sizeof(head));
        for(int i=1; i<=n; ++i)
        {
            scanf("%d",&u);
            layer[i]=u;
            vis[u]=1;
        }
        for(int i=1; i<n; ++i)
        {
            if(vis[i]&&vis[i+1])
            {
                add(edge,head,i+n,i+n+1,c);
                add(edge,head,i+n+1,i+n,c);
            }
        }
        for(int i=1;i<=n;++i)
        {
            add(edge,head,n+layer[i],i,0);
            //add(edge,head,i,n+layer[i],0);  有多个节点对应一个层的情况,大概。。。
            if(layer[i]>1)
                add(edge,head,i,n+layer[i]-1,c);
            if(layer[i]<n)
                add(edge,head,i,n+layer[i]+1,c);
        }
        for(int i=1;i<=m;++i)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(edge,head,u,v,w);
            add(edge,head,v,u,w);
        }
        spfa(edge,head,1);
        if(dis[n]<INF)
            printf("Case #%d: %d\n",cnt,dis[n]);
        else
            printf("Case #%d: -1\n",cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值