hdu4990——Reading comprehension(矩阵快速幂)

Read the program below carefully then answer the question.
#pragma comment(linker, “/STACK:1024000000,1024000000”)
#include < cstdio>
#include < iostream>
#include < cstring>
#include < cmath>
#include < algorithm>
#include < vector>

const int MAX=100000*2;
const int INF=1e9;

int main()
{
int n,m,ans,i;
while(scanf(“%d%d”,&n,&m)!=EOF)
{
ans=0;
for(i=1;i<=n;i++)
{
if(i&1)ans=(ans*2+1)%m;
else ans=ans*2%m;
}
printf(“%d\n”,ans);
}
return 0;
}

Input
Multi test cases,each line will contain two integers n and m. Process to end of file.
[Technical Specification]
1<=n, m <= 1000000000

Output
For each case,output an integer,represents the output of above program.

Sample Input
1 10
3 100

Sample Output
1
5

得出的递推公式为f(x)=f(x-1)+2*f(x-2)+1

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 10000
using namespace std;
const int N = 3;
long long m,n;
struct Matrix
{
    long long mat[N][N];
};
Matrix unit_mat=
{
    1,0,0,
    0,1,0,
    0,0,1
};
Matrix mul(Matrix a,Matrix b)
{
    Matrix res;
    for(int i=0; i<N; ++i)
        for(int j=0; j<N; ++j)
        {
            res.mat[i][j]=0;
            for(int k=0; k<N; ++k)
            {
                res.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
                res.mat[i][j]%=m;
            }
        }
    return res;
}
Matrix pow_matrix(Matrix a,long long n)
{
    Matrix res = unit_mat;
    while(n!=0)
    {
        if(n%2)
            res=mul(res,a);
        a=mul(a,a);
        n>>=1;
    }
    return res;
}
int main()
{
    Matrix tmp,arr;
    while(~scanf("%I64d%I64d",&n,&m))
    {
        if(n==1)
            printf("%I64d\n",1%m);
        else if(n==2)
            printf("%I64d\n",2%m);
        else
        {
            long long f1=1,f2=2;
            memset(arr.mat,0,sizeof(arr.mat));
            memset(tmp.mat,0,sizeof(tmp.mat));
            arr.mat[0][0]=f2;
            arr.mat[1][0]=f1;
            arr.mat[2][0]=1;
            tmp.mat[0][0]=tmp.mat[0][2]=tmp.mat[1][0]=tmp.mat[2][2]=1;
            tmp.mat[0][1]=2;
            Matrix p=pow_matrix(tmp,n-2);
            p=mul(p,arr);
            long long ans=p.mat[0][0]%m;
            printf("%I64d\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值