poj2342——Anniversary party(树形dp)

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

先入个门

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#define INF 0x3f3f3f3f
#define MAXN 10005
#define Mod 99999999
using namespace std;
int dp[MAXN][2],father[MAXN],vis[MAXN]; //dp[i][1]表示去,dp[i][0]表示不去
int n;
void dfs(int v)
{
    for(int i=1;i<=n;++i)
    {
        if(!vis[i]&&father[i]==v)
        {
            vis[i]=1;
            dfs(i);
            dp[v][1]+=dp[i][0];
            dp[v][0]+=max(dp[i][1],dp[i][0]);
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        memset(vis,0,sizeof(vis));
        memset(father,0,sizeof(father));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;++i)
            scanf("%d",&dp[i][1]);
        int l,k,root=1,flag=1;
        while(scanf("%d%d",&l,&k))
        {
            if(l==0&&k==0)
                break;
            father[l]=k;
            if(l==root||flag)
                root=l;
        }
        while(father[root])
            root=father[root];
        vis[root]=1;
        dfs(root);
        int ans=max(dp[root][1],dp[root][0]);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值