PAT(A)1003

1003. Emergency (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4


 1003.紧急情况

     作为一个城市中的紧急救援队伍的领队,你有一张属于你的国家的特殊的地图,这张地图上有一些很分散的城市,这些城市被一些路连接到一起。每个城市所有的救援队的总数和任意连接两个城市之间的路的长度都被标记在地图上。当你接到来自其他城市的紧急电话,你的任务就是带着你的队伍尽快的赶到事件发生的地点,同时尽可能多的打电话寻求帮助。

 输入:

 每个输入文件包括一个测试用例。对于每个测试用例,第一行包括四个正整数:N(<=500)-代表城市的个数(从0-N-1),M-路的个数,C1和C2分别是你目前所在的城市和你将要救援的城市。下一行包括N个整数,i位置的整数就代表第i个城市所有的救援队的个数。下面是M行,每一行包括三个整数c1,c2和L,代表每条路所连接的两个城市和这条路的长度。保证C1和C2之间至少存在一条路径。

  输出:

   对于每个测试用例,在一行中输出两个数字:一个是C1和C2之间不同的最短路径的个数,另一个是你能找到的救援队伍的个数。

    输出的数字用空格隔开,行尾没有多余空格。         

#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>
using namespace std;
const int MMAX = 1000000000;
const int MAX = 501;
int mind, cnt, maxt, n;
int weight[MAX], vis[MAX], map[MAX][MAX];
void dfs(int p, int end, int dist, int weit){
    if(p == end){
        if(dist < mind){
            cnt = 1;
            mind = dist;
            maxt = weit;
        }
        else if(dist == mind){
            cnt++;
            if(maxt < weit){
                maxt = weit;
            }
        }
        return ;
    }
    if(dist > mind)
        return ;
    for(int i=0; i<n; i++){
        if(vis[i] == 0 && map[p][i] != MMAX){
            vis[i] = 1;
            dfs(i, end, dist+map[p][i], weit+weight[i]);
            vis[i] = 0;
        }
    }

}
int main()
{
    int m, st, end, x, y, d;
    mind = MMAX;
    cnt = 0;
    scanf("%d%d%d%d", &n, &m, &st, &end);
    memset(vis, 0, sizeof(vis));
    for(int i=0; i<n; i++){
        for(int j=0; j<n; j++){
            map[i][j] = MMAX;
        }
    }
    for(int i=0; i<n; i++){
        scanf("%d", &weight[i]);
    }
    while(m--){
        scanf("%d%d%d", &x, &y, &d);
        if(map[x][y] > d){
            map[x][y] = d;
            map[y][x] = d;
        }
    }
    dfs(st, end, 0, weight[st]);
    printf("%d %d\n", cnt, maxt);
    return 0;
}


深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值