关闭

It's because your R is too old

308人阅读 评论(0) 收藏 举报
分类:
I just want to install ggplot2 for R. But it says I don't have reshape2. Then I tried to install reshape2 but it says 
" plyr package for R not available for R version 3.0.2"

I thought this is because the R version is too new. Somebody said and I tried download the plyr package and install. FINALLY I GET:
"ERROR: this R is version 3.0.2, package 'plyr' requires R >= 3.1.0" 

So, My R version is too old!!!!


I searched a lot. Only the following worked.

http://askubuntu.com/questions/218708/installing-latest-version-of-r-base

http://stackoverflow.com/questions/16093331/how-to-install-r-version-3


========================================================================================

This is an old post and I wrote it when it was impossible to install R with simple (it was installing old 2.15 version):

sudo apt-get install r-base-core

Right now you do not need to do all written below and can simply use the abovementioned command. At the time of updating it will give you 3.1 version.

Here is previous post

Uninstall old R

sudo apt-get remove r-base-core

Open sources.list

sudo nano /etc/apt/sources.list    

and add deb to it

deb http://cran.rstudio.com/bin/linux/ubuntu precise/

precise is your ubuntu name (may be different)

"precise" is 12.04. My ubuntu is 14.04. It should be "trusty"

Add key to sign CRAN packages

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9

Add specific PPA to the system

sudo add-apt-repository ppa:marutter/rdev
sudo apt-get update
sudo apt-get upgrade

installing

sudo apt-get install r-base

From R to check version

version

should give you

version.string R version 3.0.0 (2013-04-03)

Hope people will find this helpful


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:188684次
    • 积分:1436
    • 等级:
    • 排名:千里之外
    • 原创:36篇
    • 转载:33篇
    • 译文:0篇
    • 评论:8条