【原创】【区间上的贪心 第二篇】POJ 1083 Moving Tables

区间重叠 POJ 1083 Moving Tables

题目

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
这里写图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

这里写图片描述
For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
Output
The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50
Sample Output
10
20
30

题意

搬桌子,上面的房间都是奇数(1,3,5,…,399),下面的房间都是偶数(2,4,6,…,400)(这点很重要!)。中间有过道,过道很窄,只能供一个桌子搬动。每个房间最多搬进或搬出一次。搬一次十分钟。给定计划表,求最少时间。

分析

(:这道题目很简单啦啦:)
首先,我们可以把这个问题抽象为在数轴上的闭区间,每一次可以取走若干条,但要求这若干条区间都互不相交。
我们假定有一个点被覆盖了x次,说明有x个区间相交于此,那么这x个区间我们肯定只能分开取,也就是x次。
而因此,我们只需统计每个点被覆盖的次数的最大值即为答案。
数据再大一点的话,就要用到差分,不过诶嘿嘿

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define sc(a) scanf("%d",&a)
#define scc(a,b) scanf("%d %d",&a,&b)

int T,n,u,v;
int cnt[202],ans;
int main()
{
    sc(T);
    while(T--)
    {
        sc(n);
        memset(cnt,0,sizeof cnt);
        ans=0;
        for(int i=1;i<=n;i++)
        {
            scc(u,v);
            if(u%2==1) u++;
            if(v%2==1) v++;
            u/=2; v/=2;
            for(int i=min(u,v);i<=max(u,v);i++)
                cnt[i]++,ans=max(ans,cnt[i]);
        }
        printf("%d\n",ans*10);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值