uva 1583 - Digit Generator

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1 N 100, 000 .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

#include<stdio.h>

int sum(int n) {
    int sum = 0;
    int k=0;
    while( n >  0) {
        k = n%10;
        sum += k;
        n = n/10;
    }
    return sum;
}



int main() {

    int n;
    scanf("%d",&n);
    while(n--) {
        int number;
        int count = 0;
        scanf("%d",&number);
        int number1 = number;
        while(number1 > 0) {
            number1  = number1 / 10;
            count++;
        }
        int a=0;
        int i;
        for(i=number-count*9; i <= number; i++) {
            if(i + sum(i) == number) {
                a = 1;
                printf("%d\n",i);
                break;
            }
        }
        if(a  == 0) printf("0\n");
    }
    return 0;
}

小结:

这道题原先想暴力解决,但是超时了,然后就想看能不能先生成结果,再直接查询就可以了,就是简单的打表,但是发现不行,代码行数超过了,刚试过了。哈哈 ,刚刚做的实验,全部生成,然后
这里写图片描述
就这样了,后来就想到了每个数字生成元至少在这个数字减去数字位数乘以9的后面,所以范围大大减少,然后我查了下这道题的解法排名300多一点点,说明性能还不错,运行时间0.03。哈哈,刚为了想这道题还伤了女朋友的心,没能好好玩,刚在玩的时候再想题,想出来了打表的方法,然后赶紧回来试了下。这道题关键在于想法,怎样缩减范围是正确的。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值