hdu 5067 Harry And Dig Machine(BestCoder Round #14)

Harry And Dig Machine

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 332    Accepted Submission(s): 104


Problem Description
  As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm. 
  Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?
 

Input
They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m. (1n,m50) .
The next n line, each line contains m integer. The j-th number of  ith  line a[i][j] means there are a[i][j] stones on the  jth  cell of the  ith  line.(  0a[i][j]100  , and no more than 10 of a[i][j] will be positive integer).
 

Output
For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.
 

Sample Input
  
  
3 3 0 0 0 0 100 0 0 0 0 2 2 1 1 1 1
 

Sample Output
  
  
4 4
 

Source
 


知道是状压DP题,怎么都想不到思路,在最后写了个dfs交了一发,但写程序想到的剪枝忘写了,加上刚好结束,最后终测时TLE,加了剪枝就过了。由于就10个点,dfs复杂度为10!,再加个剪枝还是可以过的,状压DP的 还没会,先占个坑,会了再补上。

我的dfs代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[100][100];
struct node
{
    int x;
    int y;
}p[100];
int bbs(int x)
{
    if(x<0)
    return -x;
    return x;
}
bool visit[100];
int t;
int ans;
void dfs(int v,int temp,node u)
{
   if(temp>ans)//剪枝
   return;
    if(v==0)//递归出口
    {
        temp=temp+u.x+u.y;
        if(temp<ans)
        ans=temp;
        return;
    }
    int yu;
    for(int i=0;i<t;i++)
    {
        if(visit[i]==false)
        {
           yu=temp+bbs(p[i].x-u.x)+bbs(p[i].y-u.y);
            visit[i]=true;
            dfs(v-1,yu,p[i]);
            visit[i]=false;
        }
    }
    return;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int w;
        t=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<m;j++)
        {
            scanf("%d",&w);
            if(j==0&&i==0)
            continue;
            if(w)
            {
                p[t].x=i;
                p[t++].y=j;
            }
        }
        memset(visit,false,sizeof(visit));
        ans=99999999;
        int temp=0;
        node u;
        u.x=0;
        u.y=0;
        dfs(t,temp,u);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值