POJ 2251 Dungeon Master(BFS)

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17989 Accepted: 6977

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).

Trapped!

题意:

给出三维地图,给出入口和出口,如果可以出来,给出最小移动次数。

题解:

裸的广搜

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int inf=99999999;
char str[55][55][55];
bool vis[55][55][55];
typedef struct node
{
    int x;
    int y;
    int z;
    int cur;
}p;
int dir[6][3] = {{-1,0,0},{1,0,0},{0,-1,0},{0,1,0},{0,0,-1},{0,0,1}};
int ans;
int l,r,c;
int sx,sy,sz;
void bfs()
{
    p s;
    s.x=sx;
    s.y=sy;
    s.z=sz;
    s.cur=0;
    queue<node> q;
    q.push(s);
    while(!q.empty())
    {
        node now = q.front(); q.pop();
		node tmp;
		for (int i = 0; i < 6; ++i) {
			int x = now.x+dir[i][0];
			int y = now.y+dir[i][1];
			int z = now.z+dir[i][2];
			if (x >= l || x < 0 || y >= r || y < 0 || z >= c || z < 0) continue;
			if (vis[x][y][z]) continue;
			if (str[x][y][z] =='#') continue;
			vis[x][y][z] = true;
			tmp.x = x;
			tmp.y = y;
			tmp.z = z;
			tmp.cur = now.cur +1;
			q.push(tmp);
			if (str[x][y][z]=='E') {
				ans = tmp.cur;
				return ;
			}
		}
    }
}
int main()
{
    while(~scanf("%d%d%d",&l,&r,&c)&&l+r+c)
    {
        ans=inf;
        memset(vis,false,sizeof(vis));
        for(int i=0;i<l;i++)
        {
            for(int j=0;j<r;j++)
            {
                scanf("%s",str[i][j]);
                for(int k=0;k<c;k++)
                {
                    if(str[i][j][k]=='S')
                    {

                        sx=i;
                        sy=j;
                        sz=k;
                    }
                }
            }
        }
        bfs();
        if(ans!=inf)
        printf("Escaped in %d minute(s).\n",ans);
        else
        printf("Trapped!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值