Q and A: J2EE 1.4: The Gold Standard for Web Services

原创 2003年11月27日 00:32:00

Q and A: J2EE 1.4: The Gold Standard for Web Services

November 24, 2003
by Mark Hapner, J2EE 1.4 Specification Lead and Web Services strategist, Sun Microsystems, Inc.

Q. What is the significance of J2EE 1.4? What does this mean to the community?

A. The J2EE 1.4 specification was unanimously approved by the JCP on November 12. This platform API is the result of the collaboration of companies and distinguished individuals who agreed to work together on standards under the JCP program, while competing on implementations in the marketplace. It is also the result of the contribution made by Web Services thought leaders to develop a gold standard for Web Services. (See the open letter to the Java Community at http://www.java.sun.com/j2ee). The J2EE 1.4 specification's significance lies in its full support of the WS-I Basic profile. With this support, J2EE is the most interoperable Web Services platform ever.

Given its broad interopearbility, the specification appeals to all categories of developers for many types of applications. This led Sun to license the specification under new terms that are friendly to non-profit and open source projects. This move will further position J2EE as the platform of choice for developers. To date, the J2EE platform has nearly four million downloads and over 30 licensees.

Q. What does the J2EE 1.4 SDK include?

A. The J2EE 1.4 SDK includes:

  • The developer release of the Sun Java System Application Server 8 Platform Edition, which is the first J2EE 1.4-certified version of a fully-deployable application server
  • The new J2EE 1.4 Blueprints, which include the Adventure Builder application Documentation, demos and examples
Q. When will the Sun Java System Application Server 8 Platform Edition be commercially available? When will the Standard and Enterprise Editions be released?

A. The J2EE 1.4 SDK already includes the developer release of Sun Java System Application Server Platform Edition 8. Sun will release the commercial version in Q1 of 2004. We also plan to release Sun Java System Application Server Standard Edition 8 and Sun Java System Application Server Enterprise Edition 8 later in 2004.

Q. Have any vendors decided to license the specification?

A. Yes, we are pleased to name Apache Software Foundation and JBoss Group as the first two licensees of the J2EE specification. Apache and JBoss have taken advantage of the new licensee terms for open source projects; their decision to license 1.4 will further popularize 1.4 and will increase adoption of J2EE through a broader community of developers.

Q. Where can I get the specification and the SDK? How much does it cost?

A. The J2EE 1.4 specification and SDK are available today as a free download on the Solaris Operating Environment and Windows platforms at Sun's Developer Network site: http://java.sun.com/j2ee/download.html.

Q. How does J2EE 1.4 fit into the Java Enterprise System?

A. The Sun Java Enterprise System uses J2EE as its foundation and will offer full support for J2EE 1.4 in future releases.

Q. Will Sun offer the J2EE 1.4 specification on Linux or x86?

A. Today, Sun is releasing the J2EE 1.4 SDK on Solaris, Linux and Windows. When the Java System Application Server Platform Edition 8 is released commercially, it will support Solaris, Linux, Windows, as well as Solaris x86.

Q. Will Sun open source its Application Server and Web Server?

A. Sun has been involved in the Open Source Community from the earliest days and has a strong record in the community. While we are constantly weighing our options regarding additional Open Source initiatives, at this time, there has been no decision to adopt an open source license for the J2EE Reference Implementation or any of the company's Application Server products.

错误:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules

项目无法添加部署到Tomcat 6.0中,提示错误:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web mod...
  • xinxin19881112
  • xinxin19881112
  • 2015年07月15日 14:03
  • 1910

解决Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules项目无法加入到tomcat

解决Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules 无法加入到tomcat中问...
  • bpqdwo
  • bpqdwo
  • 2017年06月10日 16:07
  • 1308

解决Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules

Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules 1.在eclipse的wor...
  • longtingjing
  • longtingjing
  • 2016年12月10日 13:46
  • 14396

Eclipse报错:Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules

部署了tomcat服务器在Eclipse上面,遇到这个烦人的错误, 按照如下的措施就可以解决这个问题了: 将文件org.eclipse.wst.common.project.facet.core....
  • tom_code
  • tom_code
  • 2017年07月10日 20:08
  • 573

问题描述: Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules

问题描述: Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules 解决方案: Tom...
  • sixteen_cicle
  • sixteen_cicle
  • 2016年08月11日 10:58
  • 663

eclipse部署项目时:Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules

布署项目的时候出现Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4,and Java EE 5 Web modules错误;解决方法如下: 在工作...
  • qq791967024
  • qq791967024
  • 2015年08月05日 09:56
  • 2250

Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules 解决办法

用eclipse做项目时,在Dynamic web module version栏里选择了最新的3.0版本。到了部署项目时就出现了Tomcat version 6.0 only supports J2...
  • iqijun
  • iqijun
  • 2013年12月02日 14:08
  • 6303

在tomcat6.0上部署项目 报错Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules

用Spring tool suite开发的servlet项目不能加载到tomcat6.0服务器,原因是:servlet的版本高了 只要将version="3.0"改成version="2.5"...
  • spring_model
  • spring_model
  • 2016年01月21日 12:34
  • 557

配置tomcat时遇到publishes and runs j2ee and java ee web projects and server configurations to a local tom

项目时遇到记录一下,出现上述问题时候在server中无法加载tomcat 解决办法如下 你先要配置tomcat运行环境,才能在创建server时使用。...
  • paul342
  • paul342
  • 2015年09月16日 11:16
  • 3991

Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web mod

简单说一下有关“Tomcat version 7.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 and 6 Web modules”   遇见...
  • a249130
  • a249130
  • 2017年06月27日 13:27
  • 341
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Q and A: J2EE 1.4: The Gold Standard for Web Services
举报原因:
原因补充:

(最多只允许输入30个字)