关闭

开发集成工具phabricator

3544人阅读 评论(0) 收藏 举报
分类:

最近打算搞一个集成代码审核、项目管理、缺陷跟踪的系统,研究了一下TFS和Phabricator,选了Phabricator,因为它现在开源了。可以与公司现有的SVN整合,并且集成了很多功能,后面开始折腾折腾。

Phabricator 是facebook开发的一套代码审核工具,基于PHP和Mysql开发,因此最基本的要求就是LAMP环境:

  • Linux:Linux的不同发行版及变种是必需的。Mac OS X是一个可接受的Linux变种,Windows不是。Phabricator不能安装在Windows系统上。在Mac OS X,Amazon Linux,Ubuntu,RHEL和CentOS上运行的Phabricator有活跃的贡献者;
  • Apache(或nginx,或lighttpd):需要Apache 2.2.7以上版本。
  • MySQL:MySQL必需
  • PHP:需要PHP5.2以上版本

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:447473次
    • 积分:5882
    • 等级:
    • 排名:第4301名
    • 原创:147篇
    • 转载:10篇
    • 译文:0篇
    • 评论:2条
    博客专栏
    最新评论