【POJ 3070】Fibonacci(矩阵快速幂)

【POJ 3070】Fibonacci(矩阵快速幂)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12333 Accepted: 8752

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


矩快基础题,训练计划里的居然一直没看。。。或者是对数论优先忽略了……

贴上来防止时间久了忘掉,还能过来看看


代码如下:

#include <iostream>
#include <cmath>
#include <vector>
#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <list>
#include <algorithm>
#include <map>
#include <set>
#define LL long long
#define Pr pair<int,int>
#define fread() freopen("in.in","r",stdin)
#define fwrite() freopen("out.out","w",stdout)

using namespace std;
const int INF = 0x3f3f3f3f;
const int msz = 10000;
const int mod = 1e4;
const double eps = 1e-8;

int ans[2][2];
int a[2][2];
int tmp[2][2];

void pow_m(int b)
{
	for(int i = 0; i < 2; ++i)
		for(int j = 0; j < 2; ++j)
		{
			ans[i][j] = !(i^j);
			a[i][j] = !(i&j);
		}

	while(b)
	{
		if(b&1)
		{
			memset(tmp,0,sizeof(tmp));
			for(int i = 0; i < 2; ++i)
				for(int j = 0; j < 2; ++j)
					for(int k = 0; k < 2; ++k)
						tmp[i][j] = (tmp[i][j] + ans[i][k]*a[k][j])%mod;
			memcpy(ans,tmp,sizeof(tmp));
		}

		b >>= 1;

		memset(tmp,0,sizeof(tmp));
		for(int i = 0; i < 2; ++i)
			for(int j = 0; j < 2; ++j)
				for(int k = 0; k < 2; ++k)
					tmp[i][j] = (tmp[i][j] + a[i][k]*a[k][j])%mod;
		memcpy(a,tmp,sizeof(tmp));
	}
}

int main()
{
	//fread();
	//fwrite();

	int n;
	while(~scanf("%d",&n) && n != -1)
	{
		pow_m(n);
		printf("%d\n",ans[0][1]);
	}

	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值