关闭

关于myeclipse引用tomcat7引发的一些问题

377人阅读 评论(0) 收藏 举报

首先,我说一下我机器的环境如下:

JDK版本是:

MyEclipse8.5

使用MyEclipse8.5添加Tomcat遇到的问题

首先遇到一个错误 :org.apache.catalina.startup.bootstrap

解决办法如下:

eclipse:默认的配置路径不对,需要自己设置一下。

参考eclipse下的Tomcat配置及jsp网页调试中的3.4


Myeclipse:如果使用Tomcat7,会出现这个问题,因为只支持到Tomcat6

window-preferences-servers-Tomcat6.x-Path

在Path里面选择Add JAR/ZIP,加载tomcat7下的……/bin/tomcat-juli.jar。点击“OK”.

然后就可以打开服务器了。


参考资料:

http://blog.csdn.net/shirenfeigui/article/details/7708203

http://blog.csdn.net/opzoonzhuzhengke/article/details/7329440


当添加完成之后我又遇到一个错误:


百度之后,原因找到是因为jdk版本是32位但是tomcat版本是64位导致的问题,

我检查了一下,发现自己的jdk版本是正确的,上面已经截图了说明是64位的。

有些文章说删掉tomcat\bin\tcnative-1.dll 的文件就可以了,虽然不知道这个文件是做什么的

但是还是照着文章的做吧,于是我将这个文件的后缀改掉(不要删掉哦,删掉要是以后有用,想后悔都来不及了)

我改掉之后发现一下错误,

跟着路径 发现原来引用的不是jre里面的jdk好吧 

原来myeclipse自己为每一个tomcat都配置了自己的jdk环境,需要自己添加进去才可以。

点击add 添加自己下载好点tomcat。

但是……还是报错,这次看路径对了。没问题


好吧  继续百度……百度发现原来就是少了上面的那个文件导致的……这个还好 前面没有删除,后缀改回来吧……


tomcat正常运行没有报错……OK ,进行自己的下一步吧


0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:570次
    • 积分:16
    • 等级:
    • 排名:千里之外
    • 原创:1篇
    • 转载:1篇
    • 译文:0篇
    • 评论:0条
    文章分类
    文章存档