[置顶] 如何解决Maven Tycho编译OSGI bundle过程中的Missing Constraint: Bundle-RequiredExceptionEnvironment 异常?

标签: Maventychoeclipse-plugin
956人阅读 评论(0) 收藏 举报
分类:

今天笔者在用Maven tycho编译Eclipse Plugin的时候,遇到了Missing Constraint: Bundle-RequiredExceptionEnvironment issue JavaSE-1.7 这个异常信息,那么如何解决Maven编译OSGI bundle过程中的Missing Constraint: Bundle-RequiredExceptionEnvironment 异常? 其实很简单,原因是build.properties文件里的jre.compilation.profile中的JDK版本信息不正确,改成正确的“jre.compilation.profile = JavaSE-1.7”即可 。



1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:385249次
    • 积分:6339
    • 等级:
    • 排名:第4069名
    • 原创:227篇
    • 转载:0篇
    • 译文:5篇
    • 评论:157条
    博客专栏