HDU1026 Ignatius and the Princess I 【BFS】+【路径记录】

Ignatius and the Princess I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11710    Accepted Submission(s): 3661
Special Judge


Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 


 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 


 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 


 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 


 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH

题解:给定一个地图,让你从左上角走到右下角,只能上下左右四个方向,有的格子有怪兽,移动格子和打怪都要消耗时间,求到达终点所消耗的最短时间和路径。

题解:最短时间可以用优先队列求出来,路径用二维结构体数组来记录。每个节点保存它从哪儿来,该点消耗的时间。

 

#include <cstdio>
#include <queue>
#include <cstring>
#define maxn 102
using std::priority_queue;

struct Node{
    int x, y, time;
    friend bool operator<(Node a, Node b){
        return a.time > b.time;
    }
};
struct node{
    int x, y, time;
} path[maxn][maxn];
char map[maxn][maxn];
int n, m, mov[][2] = {0, 1, 0, -1, -1, 0, 1, 0};

bool check(int x, int y)
{
    return x >= 0 && y >= 0 && x < n && y < m && map[x][y] != 'X';
}

bool BFS(int& times)
{
    Node now, next;
    now.x = now.y = now.time = 0;
    priority_queue<Node> Q;
    Q.push(now);
    while(!Q.empty()){
        now = Q.top(); Q.pop();
        if(now.x == n - 1 && now.y == m - 1){
            times = now.time; return true;
        }
        for(int i = 0; i < 4; ++i){
            next = now;
            next.x += mov[i][0]; next.y += mov[i][1];
            if(!check(next.x, next.y)) continue;
            ++next.time;
            path[next.x][next.y].x = now.x;
            path[next.x][next.y].y = now.y;
            path[next.x][next.y].time = 0;
            if(map[next.x][next.y] != '.'){
                next.time += map[next.x][next.y] - '0';
                path[next.x][next.y].time = map[next.x][next.y] - '0';
            }        
            map[next.x][next.y] = 'X'; Q.push(next);
        }
    }
    return false;
}

void printPath(int times, int x, int y)
{
    if(times == 0) return;
    times -= path[x][y].time;
    printPath(times - 1, path[x][y].x, path[x][y].y);
    printf("%ds:(%d,%d)->(%d,%d)\n", 
        times++, path[x][y].x, path[x][y].y, x, y);
    while(path[x][y].time--)
        printf("%ds:FIGHT AT (%d,%d)\n", times++, x, y);    
}

int main()
{
    int times, i;
    while(scanf("%d%d", &n, &m) != EOF){
        for(i = 0; i < n; ++i)
            scanf("%s", map[i]);
        memset(path, 0, sizeof(path));
        if(BFS(times)){
            printf("It takes %d seconds to reach the target position, let me show you the way.\n", times);
            printPath(times, n - 1, m - 1);
        }else puts("God please help our poor hero.");
        puts("FINISH");
    }
    return 0;
}


 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值