HDU1142 A Walk Through the Forest 【SPFA】+【记忆化搜索】

A Walk Through the Forest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5688    Accepted Submission(s): 2089


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2 4
 

Source

题意:若a到终点的距离大于b到终点的距离,而且a跟b联通,那么可以从a经过b到达终点,求从起点到终点的路有多少条。
题解:SPFA求终点到各个点的最短路径,DFS搜索可行路的条数。


#include <stdio.h>
#include <string.h>
#include <queue>
#define maxn 1002
#define inf 0x3f3f3f3f
using std::queue;

int map[maxn][maxn];
int dist[maxn], dp[maxn];
bool vis[maxn];

void SPFA(int s, int n)
{
	int i, u, tmp;
	for(i = 0; i <= n; ++i){
		dist[i] = inf; vis[i] = false;
	}
	queue<int> Q;
	u = s; vis[u] = 1; dist[u] = 0;
	Q.push(u);
	while(!Q.empty()){
		u = Q.front(); Q.pop();
		vis[u] = false;
		for(i = 1; i <= n; ++i){
			if(map[u][i] == inf) continue;
			tmp = map[u][i] + dist[u];
			if(tmp < dist[i]){
				dist[i] = tmp;
				vis[i] = true;
				Q.push(i);
			}
		}
	}
}

int DFS(int s, int n)
{
	if(dp[s]) return dp[s];
	if(s == 2) return 1;
	int i, ans = 0;
	for(i = 1; i <= n; ++i)
		if(map[s][i] != inf && dist[i] < dist[s]){
			ans += DFS(i, n);
		}
	return dp[s] = ans;
}

int main()
{
	int n, m, u, v, d, i, j;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i <= n; ++i){
			for(j = 0; j <= n; ++j)
				map[i][j] = inf;
			map[i][i] = 0;
		}
		for(i = 0; i < m; ++i){
			scanf("%d%d%d", &u, &v, &d);
			map[u][v] = map[v][u] = d;
		}
		SPFA(2, n);
		for(i = 0; i <= n; ++i) dp[i] = 0;
		printf("%d\n", DFS(1, n));
	}
	return 0;
}

Dijkstra 实现:

#include <stdio.h>
#include <string.h>
#define maxn 1002
#define inf 0x3f3f3f3f

int map[maxn][maxn];
int dist[maxn], dp[maxn];
bool vis[maxn];

int getNext(int n)
{
	int u = -1, tmp = inf, i;
	for(i = 1; i <= n; ++i)
		if(!vis[i] && tmp > dist[i]){
			tmp = dist[i]; u = i;
		}
	return u;
}

void Dijkstra(int s, int n)
{
	int i, u, tmp;
	for(i = 0; i <= n; ++i){
		dist[i] = inf; vis[i] = false;
	}
	u = s; dist[u] = 0;
	while(u != -1){
		for(i = 1; i <= n; ++i){
			if(map[u][i] == inf) continue;
			tmp = map[u][i] + dist[u];
			if(tmp < dist[i]) dist[i] = tmp;
		}
		vis[u] = true;
		u = getNext(n);
	}
}

int DFS(int s, int n)
{
	if(dp[s]) return dp[s];
	if(s == 2) return 1;
	int i, ans = 0;
	for(i = 1; i <= n; ++i)
		if(map[s][i] != inf && dist[i] < dist[s]){
			ans += DFS(i, n);
		}
	return dp[s] = ans;
}

int main()
{
	int n, m, u, v, d, i, j;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i <= n; ++i){
			for(j = 0; j <= n; ++j)
				map[i][j] = inf;
			map[i][i] = 0;
		}
		for(i = 0; i < m; ++i){
			scanf("%d%d%d", &u, &v, &d);
			map[u][v] = map[v][u] = d;
		}
		Dijkstra(2, n);
		for(i = 0; i <= n; ++i) dp[i] = 0;
		printf("%d\n", DFS(1, n));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值