HDU 1031 Design T-Shirt(结构体排序)

Design T-Shirt

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10218    Accepted Submission(s): 4877


Problem Description
Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.
 

Input
The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.
 

Output
For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.
 

Sample Input
  
  
3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2
 

Sample Output
  
  
6 5 3 1 2 1
 

Author

CHEN, Yue


题目大意:输入三个数n、m、k,分别表示n个人、总共有m件物品,要取k件物品,下面n行m列输入这n个人对这m件商品的满意度,求出使这n个人满意度最大的k件物品。


没有什么难点,就是结构体排序。首先,定义结构体,内含物品满意度和物品编号,将n个人对m件物品的满意度累加存入,然后对满意度进行排序;

再把满意度最高的k件商品取出,对其物品编号进行排序,按照从大到小输出即可;

注意输出格式,防止PE。


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#define N 111
using namespace std;

int b[N];

struct node{
    double s;
    int index;
}a[N];

int cmp1(node a,node b){
    return a.s > b.s;
}

int cmp2(int a,int b){
    return a > b;
}

int main(){
        int m,n,k;
        while(~scanf("%d%d%d",&n,&m,&k)){
            double satisfaction;
            for(int i=0;i<m;i++)
                a[i].s = 0;
            memset(b,0,sizeof(b));
            for(int i=0;i<n;i++){
                for(int j=0;j<m;j++){
                    scanf("%lf",&satisfaction);
                    a[j].s += satisfaction;
                    a[j].index = j+1;
                }
            }
            sort(a,a+m,cmp1);
            for(int i=0;i<k;i++){
                b[i]=a[i].index;
            }
            sort(b,b+k,cmp2);
            for(int i=0;i<k;i++){
                if(i)
                    printf(" ");
                printf("%d",b[i]);
            }
            printf("\n");
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值