Symmetry UVa 1595(水题)

题目描述:

The figure shown on the left is left-right symmetric as it is possible to fold the sheet of paper along a vertical line, drawn as a dashed line, and to cut the figure into two identical halves. The figure on the right is not left-right symmetric as it is impossible to find such a vertical line.

\epsfbox{p3226.eps}

Write a program that determines whether a figure, drawn with dots, is left-right symmetric or not. The dots are all distinct.

Input 

The input consists of T test cases. The number of test cases T is given in the first line of the input file. The first line of each test case contains an integer N , where N ( 1$ \le$N$ \le$1, 000) is the number of dots in a figure. Each of the following N lines contains the x-coordinate and y-coordinate of a dot. Both x-coordinates and y-coordinates are integers between -10,000 and 10,000, both inclusive.

Output 

Print exactly one line for each test case. The line should contain `YES' if the figure is left-right symmetric. and `NO', otherwise.

The following shows sample input and output for three test cases.

Sample Input 

3                                            
5                                            
-2 5                                         
0 0 
6 5 
4 0 
2 3 
4 
2 3 
0 4 
4 0 
0 0 
4
5 14 
6 10
5 10 
6 14

Sample Output 

YES 
NO 
YES

题目大意:

在平面内给至多1000个点,找到一个垂直于x轴的直线,使得这些点沿直线左右对称

题目思路:

把给出的点按x大小排序,之后找到中间的点(奇数个点)或者中间两个点的中轴线(偶数个点)判断是否沿这条直线对称就可以了(注意用double)

#include<stdio.h>
#include<algorithm>
using namespace std;
struct point { int x, y; }a[1005];
int n;
int sgn(double x)
{
	if (fabs(x) < 1e-8)return 0;
	else if (x > 0)return 1;
	return -1;
}
int cmp(point a, point b)
{
	return a.x < b.x;
}
int ok(double m)
{
	int j;
	for (int i = 0; i < n; i++)
	{
		double x1 = 2 * m - a[i].x, y1 = a[i].y;
		for (j = 0; j < n; j++)
			if (!sgn(a[j].x -x1)&&!sgn(a[j].y-y1))break;
		if (j == n)return 0;
	}
	return 1;
}
int main()
{
	int t;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d%d", &a[i].x, &a[i].y);
		sort(a, a + n, cmp);
		double x1 = a[(n - 1) / 2].x,x2=x1;
		if(n%2==0)x2 = a[(n - 1) / 2 + 1].x;
		if (ok(x1) || !(n % 2) &&ok((x1+x2)/2))printf("YES\n");
		else printf("NO\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值