【HDU 1007】Quoit Design(分治法)

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 52560    Accepted Submission(s): 13857


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 

思路:暴力循环所有情况,显然会超时,考虑分治的思想将问题分为子问题分别解决后合并。
代码
#include<stdio.h>
#include<math.h>
#include<algorithm> 
using namespace std;
struct point {
	double x;
	double y;
}ar[100005],br[100005]; //br用于存放特殊情况的可疑点 
double val,ans;

bool cmp_x(struct point a,struct point b);//自定义比较函数(用在sort里) 
bool cmp_y(struct point a,struct point b);
double dist(struct point a,struct point b);//计算距离 
double solve(int l,int r); //解答函数,分治思想 

int main(){
	int n,i,j;
	while(scanf("%d",&n)!=EOF&&n){
	for(i=0;i<n;i++) scanf("%lf %lf",&ar[i].x,&ar[i].y);
	sort(ar,ar+n,cmp_x);
	ans=solve(0,n-1);
	printf("%.2f\n",ans/2);
}
	return 0;
}

bool cmp_x(struct point a,struct point b){
	if(a.x==b.x) return a.y<b.y;
	else return a.x<b.x;
}

bool cmp_y(struct point a,struct point b){
	if(a.y==b.y) return a.x<b.x;
	else return a.y<b.y;
}

double dist(struct point a,struct point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

double solve(int l,int r){
	if(r-1==l) return dist(ar[l],ar[r]);  //只有两个点的情况 
	if(r-2==l) {                          //三个点的情况 
		double s1=dist(ar[l],ar[l+1]);
		double s2=dist(ar[l],ar[r]);
		double s3=dist(ar[l+1],ar[r]);
		return min(s1,min(s2,s3));
	}
	
	int mid=(l+r)/2;                      //分而治之  
	val=min(solve(l,mid),solve(mid+1,r)); //取两边距离的最小值 
//特殊情况,若最近距离分别在分断处左右 
	int k=0,i,j; //筛选                          
	for(i=l;i<=r;i++){
		if(fabs(ar[i].x-ar[mid].x)<val){  //若x1-x2>=val(距离),直接跳过,反之存进br数组 
			br[k].x=ar[i].x;
			br[k].y=ar[i].y;
			k++;
		}
	}
	sort(br,br+k,cmp_y);				  //按y从小到大排序 
	
	for(i=0;i<k-1;i++){
		for(j=i+1;j<k&&((br[j].y-br[i].y)<val);j++){//y已按从小到大排序,若(b[j].y-b[i].y)>=val,则后面的肯定更大。   
			val=min(val,dist(br[j],br[i]));
		}
	}
	return val;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值