hdoj 1116 Play on Words 【并查集 + 欧拉】

Play on Words

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5903    Accepted Submission(s): 1973


Problem Description
Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.
 

Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.".
 

Sample Input
  
  
3 2 acm ibm 3 acm malform mouse 2 ok ok
 

Sample Output
  
  
The door cannot be opened. Ordering is possible. The door cannot be opened.
 
有向图欧拉通路,欧拉回路判定:回路--所有点出度,入度相等;通路--只有两个端点的出度,入度不同且其中一个点的出度减去入度等于1,另一个入度减去出度等于1;
 
并查集+欧拉实现代码:
 
#include<stdio.h>
#include<iostream>
#include<vector> 
#include<string.h>
#define max 30
using namespace std;
char str[1000];
int in[max],out[max],p[max];//记录出度和入度 
int set[max],visit[max];//set记录元素父节点,visit判断该元素是否出现 
int find(int p)
{
    int child=p;
    int t;
    while(p!=set[p])
    p=set[p];
    while(child!=p)
    {
        t=set[child];
        set[child]=p;
        child=t;
    }
    return p;
}
void merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    set[fx]=fy; 
}
int main()
{
    int t,n,i,j,l,x,y,exist,sum;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=1;i<=26;i++)
        {
            set[i]=i;
            visit[i]=0;//记录有没有出现 
            in[i]=out[i]=p[i]=0; 
        }
        for(i=0;i<n;i++)
        {
            scanf("%s",str);//把 单词头尾看成两个点 
            l=strlen(str);
            x=str[0]-'a'+1;
            y=str[l-1]-'a'+1;
            in[y]++;
            out[x]++;
            visit[x]=visit[y]=1;
            merge(x,y);//合并 
        }
        exist=0;
        for(i=1;i<=26;i++)
        {
            if(visit[i]&&set[i]==i)
            {
                exist++;
                if(exist>1)
                break;
            }
        }
        if(exist>1)//没有连通 
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        sum=0;
        for(i=1;i<=26;i++)
        {
            if(visit[i]&&in[i]!=out[i])
            {
                p[sum++]=i;//记录出度和入度不等的点 
            }
        }
        if(sum==0)//欧拉回路 
        printf("Ordering is possible.\n");
        else if(sum==2&&(out[p[0]]-in[p[0]]==1&&in[p[1]]-out[p[1]]==1||in[p[0]]-out[p[0]]==1&&out[p[1]]-in[p[1]]==1))//欧拉通路 
        printf("Ordering is possible.\n");
        else 
        printf("The door cannot be opened.\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值