hdoj 1710 Binary Tree Traversals 【二叉树由前序和中序求后序】

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4198    Accepted Submission(s): 1900


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
 

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
 

Output
For each test case print a single line specifying the corresponding postorder sequence.
 

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
 

Sample Output
  
  
7 4 2 8 9 5 6 3 1
 

题意:给出一个二叉树的前序和中序,让你求后序。

 

思路:通过前序序列可判断树的根节点并在中序序列中找到根节点位置,记录根节点;由中序序列可知在根节点左边的为左子树,右边的为右子树,把树去掉根节点分成两棵子树,对每一棵子树的子根节点进行同样的查找;该过程一直到 子树不能分 为止。



ac代码:

#include <cstdio>
#include <cstring>
#define MAX 1000+10
using namespace std;
int preorder[MAX];
int inorder[MAX];
int postorder[MAX];
void build(int n, int pre, int in, int rec)
{//n当前子树节点数  pre当前子树根节点在前序序列中位置 in中序序列开始查询根节点的起始位置 rec数组下标 
	int i;
	if(n <= 0) return ;//子树不能再分 
	for(i = 0; ; i++) 
	{
		if(preorder[pre] == inorder[in+i])//查找子树根节点位置 
		break;
	}
	build(i, pre+1, in, rec);//左子树继续查找 
	build(n-i-1, pre+i+1, in+i+1, rec+i);//右子树继续查找 
	postorder[n-1+rec] = preorder[pre];//因为后序是先左子树 再右子树的 注意下标的变化 
}
int main() 
{
	int n;
	int i, j;
	while(scanf("%d", &n) != EOF)
	{
		for(i = 0; i < n; i++)
		scanf("%d", &preorder[i]);
		for(i = 0; i < n; i++)
		scanf("%d", &inorder[i]);
		build(n, 0, 0, 0);
		for(i = 0; i < n; i++)//输出后序序列 
		i == 0 ? printf("%d", postorder[i]) : printf(" %d", postorder[i]);
		printf("\n");
	} 
	return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值