hdoj 4738 Caocao's Bridges 【无向图边-双联通 求所有桥中权值最小的】



Caocao's Bridges

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1998    Accepted Submission(s): 713


Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn't give up. Caocao's army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao's army could easily attack Zhou Yu's troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao's army could be deployed very conveniently among those islands. Zhou Yu couldn't stand with that, so he wanted to destroy some Caocao's bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn't be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
 

Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn't succeed any way, print -1 instead.
 

Sample Input
  
  
3 3 1 2 7 2 3 4 3 1 4 3 2 1 2 7 2 3 4 0 0
 

Sample Output
  
  
-1 4
 
题意:曹操为了打败周瑜,在江东的很多岛屿之间修建了很多桥梁,使这些岛屿联了起来,当然每个桥都有对应的士兵去守卫。现在周瑜只有一个诸葛亮给的炸弹,他想要隔断曹操岛屿与岛屿间的联系,他必须派人去炸掉某一个桥梁,但是他派去的士兵数目不能少于这个桥梁上曹操的士兵数。问周瑜能否隔断曹操岛屿间的联系,若能则输出他需要派去的最少士兵数目,反之输出-1。

思路:求出无向图的所有桥,再找到权值最小的输出即可。 注意若图本来是非连通的,不需要派人去炸桥梁;若某个桥上士兵数为0,那么只需要派出一人即可。


tarjan算法:

写好算法后,测试数据都没过,悲催啊。。。

最后知道有重边,没办法改呗。。。

这个代码有点水 跑了982ms: 后面有更牛的


#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 1000+10
#define MAXM 2000000+10
#define INF 1000000
using namespace std;
struct Edge
{
	int from, to, val, next, num;//num标记是否有重边 
	bool cut;
}edge[MAXM];
int head[MAXN], top;
int low[MAXN], dfn[MAXN];
int recdfn;
bool exist;
int N, M;
void init()
{
	top = 0;
	memset(head, -1, sizeof(head));
} 
void addEdge(int u, int v, int w)
{
	int i;
	for(i = head[u]; i != -1; i = edge[i].next)
	{
		if(edge[i].to == v)
		break;
	} 
	if(i != -1)
	edge[i].num = 1;
	else
	{
		Edge E = {u, v, w, head[u], 0, 0};
		edge[top] = E;
		head[u] = top++;
	}
}
void getMap()
{
	int u, v, w;
	while(M--)
	{
		scanf("%d%d%d", &u, &v, &w);
		addEdge(u, v, w);
		addEdge(v, u, w); 
	}
} 
void tarjan(int u, int fa)
{
	low[u] = dfn[u] = ++recdfn;
	for(int i = head[u]; i != -1; i = edge[i].next)
	{
		int v = edge[i].to;
		if(v == fa)
		continue;
		if(!dfn[v])
		{
			tarjan(v, u);
			low[u] = min(low[u], low[v]);
			if(low[v] > dfn[u] && edge[i].num == 0)
			edge[i].cut = edge[i^1].cut = true;
		} 
		else low[u] = min(low[u], dfn[v]);
	}
} 
void find_edgecut()
{
	memset(low, 0, sizeof(low));
	memset(dfn, 0, sizeof(dfn));
	recdfn = 0;
	exist = true;
	tarjan(1, 1);
	for(int i = 1; i <= N; i++)
	{
		if(!dfn[i])
		{
			exist = false;
			return ;
		}
	} 
}
void solve()
{
	if(!exist)
	printf("0\n");
	else
	{
		int ans = INF;
		for(int i = 0; i < top; i++)
		{
			if(edge[i].cut)
			ans = min(ans, edge[i].val);
		} 
		if(ans == INF)
		printf("-1\n");
		else if(ans == 0)
		printf("1\n");
		else
		printf("%d\n", ans);
	}
}
int main()
{
	while(scanf("%d%d", &N, &M), N||M)
	{
		init();
		getMap();
		find_edgecut();
		solve();
	} 
	return 0;
}





看了九野大大的博客学了不少东西。

跑了152ms:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAXN 1000+10 
#define MAXM 1000000+10 
#define INF 10000+10 
using namespace std;
struct Edge
{
    int from, to, val, next, num, cut;
}edge[MAXM];
int head[MAXN], top;
int low[MAXN];
int dfn[MAXN];//记录点在DFS树中的深度优先数
int recdfn;
bool exist;
void init()
{
    top = 0;
    memset(head, -1, sizeof(head));
} 
void addEdge(int u, int v, int w)
{
    Edge E = {u, v, w, head[u], 0, 0};
    edge[top] = E;
    head[u] = top++;
    Edge E1 = {v, u, w, head[v], 0, 0};
    edge[top] = E1;
    head[v] = top++;
}
void getMap(int m)
{
    int a, b, c;
    while(m--)
    {
        scanf("%d%d%d", &a, &b, &c);
        addEdge(a, b, c); 
    }
}
void tarjan(int u, int fa)
{
    low[u] = dfn[u] = ++recdfn;
    int have  = 0;
    for(int i = head[u]; i != -1; i = edge[i].next)
    {
        int v = edge[i].to;
        if(!have && v == fa)//重边 一定不是桥  重边有效 
        {
        	have++;
        	continue;
        } 
        if(!dfn[v])
        {
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
            if(low[v] > dfn[u] && edge[i].num == 0)//u -> v为桥 
            {
                edge[i].cut = true;
                edge[i^1].cut = true;
            }
        }
        else low[u] = min(low[u], dfn[v]); 
    }
}
void find_edgecut(int l, int r)
{
    memset(low, 0, sizeof(low));
    memset(dfn, 0, sizeof(dfn));
    exist = true;
    recdfn = 0;
    tarjan(l, l);//连通图 只需一次就能遍历完所有的点 
    for(int i = l; i <= r; i++) 
    {
        if(!dfn[i])//若还存在点没有遍历到 说明图本身就是非连通通图 
        {
            exist = false;
            return ;
        }
    } 
}
int main()
{
    int N, M;
    while(scanf("%d%d", &N, &M), N||M)
    {
        init();
        getMap(M);
        find_edgecut(1, N);
        if(!exist) 
        printf("0\n");
        else
        {
            int ans = INF;
            for(int i = 0; i < top; i++)
            {
                if(edge[i].cut)
                ans = min(ans, edge[i].val);
            }
            if(ans == INF)//找不到桥
            printf("-1\n");
            else if(ans == 0)
            printf("1\n");//至少需要一个人。。。 
            else
            printf("%d\n", ans); 
        } 
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值