hdoj 5095 Linearization of the kernel functions in SVM 【模拟】

Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2231    Accepted Submission(s): 597


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <-> u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input
  
  
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output
  
  
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 

题意:给你10个数字,让你用前9个数字乘以对应的一个字母p、q、r、u、v、w、x、y、z,再加上最后一个数字可以构成一个表达式。最后输出表达式。

给几组测试数据:

输入
10
1 1 1 1 1 1 1 1 1 1
0 0 0 0 0 0 0 0 0 0
1 1 1 1 1 1 1 1 1 0
0 0 0 0 0 0 0 0 0 1

输出
p+q+r+u+v+w+x+y+z+1
0
p+q+r+u+v+w+x+y+z
1


这辈子不想做模拟。。。

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#define LL long long
void output(int pos)
{
    switch(pos)
    {
        case 1: printf("p"); break;
        case 2: printf("q"); break;
        case 3: printf("r"); break;
        case 4: printf("u"); break;
        case 5: printf("v"); break;
        case 6: printf("w"); break;
        case 7: printf("x"); break;
        case 8: printf("y"); break;
        case 9: printf("z"); break;
    }
}
int main()
{
    int t;
    LL a[20];
    scanf("%d", &t);
    while(t--)
    {
        for(int i = 1; i <= 10; i++)
            scanf("%lld", &a[i]);
        int k = 0; int sum = 0;
        for(int i = 1; i <= 9; i++)
        {
            if(a[i] == 0)
            {
                sum++;
                continue;
            }
            if(a[i] > 0)
            {
                if(k > 0) printf("+");
                if(a[i] != 1)//1的情况
                    printf("%lld", a[i]);
                k++;
            }
            else
            {
                if(a[i] != -1)
                    printf("%lld", a[i]);
                else
                    printf("-");
                k++;
            }
            output(i);
        }
        //处理最后一位
        if(a[10] == 0 && sum == 9)
            printf("0\n");
        else if(a[10] == 0)
            printf("\n");
        else //不为0
        {
            if(a[10] > 0)
            {
                if(sum == 9)
                    printf("%lld\n", a[10]);
                else
                    printf("+%lld\n", a[10]);
            }
            else
                printf("%d\n", a[10]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值