hdoj 3183 A Magic Lamp 【RMQ区间取数】



A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2525    Accepted Submission(s): 989


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
      
      
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
      
      
13 1 0 123 321
 



题意:给定一个用字符串表示的大数str和一个数M,让你从左到右取出|str|-M个数,使得取出的数最小,并输出。【去掉前导0】


思路:RMQ区间取数,维护的是区间下标最小的最小值。

dp[i][j]记录以i开头的长度为1<<j的区间里面下标最小的最小值。


AC代码:


#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f3f
#define eps 1e-4
#define MAXN (1000+10)
#define MAXM (1000000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 100000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
int dp[MAXN][32];
int a[MAXN];
int N;
void RMQ_init()
{
    for(int i = 1; i <= N; i++)
        dp[i][0] = i;
    for(int j = 1; (1<<j) <= N; j++)
        for(int i = 1; i + (1<<j)-1 <= N; i++)
            dp[i][j] = a[dp[i][j-1]] <= a[dp[i+(1<<(j-1))][j-1]] ? dp[i][j-1] : dp[i+(1<<(j-1))][j-1];
}
int Query(int L, int R)
{
    int k = 0;
    while((1<<(k+1)) <= R-L+1) k++;
    return a[dp[L][k]] <= a[dp[R-(1<<k)+1][k]] ? dp[L][k] : dp[R-(1<<k)+1][k];
}
int main()
{
    char str[1010]; int M;
    while(scanf("%s%d", str, &M) != EOF)
    {
        N = strlen(str);
        for(int i = 0; i < N; i++)
            a[i+1] = str[i] - '0';
        RMQ_init();
        int top = 0, pos = 1;
        for(int i = M+1; i <= N; i++)
        {
            pos = Query(pos, i);
            str[top++] = a[pos] + '0';
            pos++;
        }
        pos = -1;
        for(int i = 0; i < top; i++)
            if(str[i] != '0')
            {
                pos = i;
                break;
            }
        if(pos == -1)
            printf("0\n");
        else
        {
            for(; pos < top; pos++)
                printf("%c", str[pos]);
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值