北大ACM 1050 To the Max

58 篇文章 0 订阅
53 篇文章 0 订阅
To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 37857 Accepted: 19954

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
 
 
#include <stdio.h>
#define N 100
int MaxSum(int n, int *a)
{
	int b = 0, sum = -999, i;
	for(i=0; i < n; i++)
	{
		if(a[i] > 0) b+=a[i];
		else b = a[i];
		if(b > sum) sum = b;
	}
	return sum;
}

int MaxSubSum(int *a, int left, int right)  
{  
    int sum = -999, center, leftSum, rightSum;  
    int i, lefs = 0, s1 = 0, rights = 0, s2 = 0;  
    if(left==right) sum=a[left] >0?a[left]:0;  
    else{  
        center = (left+right)/2;  
        leftSum = MaxSubSum(a, left, center);  
        rightSum = MaxSubSum(a, center+1, right);  
        for(i = center; i>=left; i--)  
        {  
            lefs += a[i];  
            if(lefs>s1) s1 = lefs;     
        }  
        for(i = center+1; i<=right; i++)  
        {  
            rights += a[i];  
            if(rights > s2) s2 = rights;  
        }  
        sum = s1+s2;  
        if(sum < leftSum) sum = leftSum;  
        if(sum < rightSum) sum = rightSum;         
    }  
    return sum;  
}  
  
int MaxSum_3(int n,int *a)  
{  
    return MaxSubSum(a,0, n-1);  
}
// m is row, n is column
int MaxSum_2(int m, int n, int a[][N])
{
	int i, j, k, sum = -9999,max;
	int *b = (int *)malloc(n*sizeof(int));
	for(i = 0; i < m; i++)
	{
		for(j = 0; j < n; j++) b[j] = 0;
		for(k = i; k < m; k++)
		{
			for(j = 0; j < n; j++) b[j]+=a[k][j];
			max = MaxSum_3(n, b);
			if(max > sum) sum = max;
		}
	}
	return sum;
}

int main()
{
	int a[N][N];
	int n, j, i;
	while(scanf("%d", &n)==1)
	{
		for(j = 0; j < n; j++)
			for(i = 0; i < n; i++)
				scanf("%d",&a[j][i]);
		printf("%d\n",MaxSum_2(n,n,a));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值