UVa 679 - Dropping Balls 数学分析

Dropping Balls 

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag's current value at this node is false, then the ball will first switch this flag's value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from thetrue to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.


For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.


Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.


Now consider a number of test cases where two values will be given for each test. The first value isD, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.


For each test cases the range of two parameters D and I is as below: 

\begin{displaymath}2 \le D \le 20, \mbox{ and } 1 \le I \le 524288.\end{displaymath}

Input 

Contains  l +2 lines.

Line 1 		 I the number of test cases 
Line 2 		 $D_1 \ I_1$
test case #1, two decimal numbers that are separatedby one blank 
... 		 		 
Line k+1 $D_k \ I_k$
test case #k 
Line l+1 $D_l \ I_l$
test case #l 
Line l+2 -1 		 a constant -1 representing the end of the input file

Output 

Contains  l  lines.

Line 1 		 the stop position P for the test case #1 
... 		 
Line k the stop position P for the test case #k 
... 		 
Line l the stop position P for the test case #l

Sample Input 

5
4 2
3 4
10 1
2 2
8 128
-1

Sample Output 

12
7
512
3
255



Miguel Revilla 
2000-08-14


#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int MAX = 20;

int data[1<<MAX];

int main()
{
//	freopen("in.txt","r",stdin);
	int nCase;
	while(scanf("%d",&nCase)==1 && nCase != -1)
	{
		while(nCase--)
		{
			int n, count;
			scanf("%d %d", &n, &count);
			memset(data, 0, sizeof(data));
			int k;
			int maxNum = (1<<n) - 1;
			for(int i=0; i < count; i++)
			{
				k=1;
				for(;;)
				{
					data[k] = !data

[k];
					k = (data[k]?

2*k:2*k+1);
					if(k > maxNum) 

break;
				}
			}
			printf("%d\n", k/2);
		}
	}
	return 0;
}

上面是一份超时的代码,很明显可以看出这是模拟小球下落的过程


,但是上述的数据最大是20, 那么就一共可能有10000组数据,


TLE 是必然的结果。

#include <cstdio>

int main()
{
//	freopen("in.txt","r",stdin);
	int nCase;
	while(scanf("%d", &nCase) && nCase!=-1)
	{
		while(nCase--)
		{
			int D,I;
			scanf("%d%d",&D, &I);
			int k =1;
			for(int i=0; i < D-1; i++)
			{
			//	if(I%2){k *= 2; I = (I

+1)/2;}
			//	else {k = k*2+1; I /= 

2;}

				k = (k<<1)+1-(I%2);
 				I=(I>>1)+(I%2);
			}
			printf("%d\n", k);
		}
	}
	return 0;
}



这一份代码在UVa 的排名中相差最后的20名只有0.005 s ,  可是


想提高这么短短的时间我已经无力回天了
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值