Redhat6.5——解决yum功能不能正常使用

原创 2016年08月28日 18:09:30

以前或多或少接触过linux服务器,由于是服务器上的,很多东西也没去玩过。要想多研究,还是得自己弄一个linux系统。由于正常工作,还是接触windows更多,双系统显然没有那么方便,所以决定弄个虚拟机。

虚拟机资源

网上大致看了下,用vm比较多,系统版本选择的是Redhat6.5。具体安装过程就不说了,网上比较多。
分享一下资源(redhat6.5+vmware):
链接:http://pan.baidu.com/s/1c1Vl6ms 密码:gu1b

解决yum功能不能用

This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. 

如果你使用yum命令安装软件时,出现这个提示,那么你很可能需要这个解决方案。

1.下载yum替换软件包

所需文件有:

python-iniparse-0.3.1-2.1.el6.noarch.rpm
yum-metadata-parser-1.1.2-16.el6.x86_64.rpm
yum-3.2.29-40.el6.centos.noarch.rpm yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

所需要的软件可通过http://mirrors.163.com/centos下载。
这是我已下好的资源:
链接:http://pan.baidu.com/s/1c2HoEC4 密码:tyug

2.卸载原生yum

#rpm -qa | grep yum | xargs rpm -e --nodeps

3.重新安装yum

先上传第一步下载的包到xxx目录,然后cd目录到该xxx目录。
一次输入以下命令安装:

#rpm -ivh python-iniparse-0.3.1-2.1.el6.noarch.rpm
#rpm -ivh yum-metadata-parser-1.1.2-16.el6.x86_64.rpm
#rpm -ivh yum-3.2.29-40.el6.centos.noarch.rpm yum-plugin-fastestmirror-1.1.30-14.el6.noarch.rpm

4.下载CentOS6-Base-163.repo文件

通过命令wget:

#wget http://mirrors.163.com/.help/CentOS6-Base-163.repo

下载CentOS6-Base-163.repo文件,下载完毕后,将该文件拷到/etc/yum.repo.d目录下。提示:在/etc/yum.repo.d下有一个原生的CentOS6-Base-163.repo文件,建议对自己不熟悉的配置文件都做一个备份,也许现在用不着,但以后你可能会感谢自己的这个小习惯。

5.更改配置

将CentOS6-Base-163.repo文件中,$releasever全部替换成Centos的版本号。比如,我这个版本是Redhat6.5,那么将$releasever全部替换成6。
可以用一下命令替换:

:%s/$releasever/6/g

6.清楚缓存,获取yum列表

清除原有缓存:

yum clean all 

获取yum列表:

yum makecache  

等待两分钟,会出现:
Metadata Cache Created
至此,yum可正常使用。

参考文章:http://www.th7.cn/system/lin/201402/50472.shtml

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

red hat 6.5 Linux.6.5 安装yum

red hat 6.5 红帽企业Linux.6.5 yum This system is not registered to Red Hat Subscription Management. Yo...

centos 不小心把yum删除了的拯救办法

今天遇到一个问题,centos6.8系统上的yum命令被删除,导致没有了yum , 找了许多办法都没有解决,最后通过如下两个文档解决了 1、参考一 http://blog.sina.com.cn...

Red Hat 6.5修改yum源

由于 redhat的yum在线更新是收费的,如果没有注册的话不能使用,如果要使用,需将redhat的yum卸载后,重启安装,再配置其他源 解决办法: 1、首先到http://mirrors.163.c...

RHEL6/Centos 解决无法使用YUM源问题

 RHEL的YUM源需要注册用户才能更新使用,由于CentOS和RHEL基本没有区别,并且CentOS已经被REHL收购。所以将RHEL的YUM源替换为CentOS即可。 问题如下: [ro...

yum命令不能使用的相关错误

yum (Yellowdog Updater Modified)是一个集与查找,安装,更新和删除程序的Linux软件。它运行在RPM包兼容的Linux发行版本上,如:RedHat, Fedora, S...

解决Linux国内yum源不能用的问题

其实现在很多说国内yum在线源无法使用,其实就是yum配置源文件中baseurl指定的软件库地址有错,不能根据baseurl所指定的地址找到repodata目录中的repomd.xml文件,所以yum...

解决redhat自带yum不能用的问题

[root@localhost ~]# yum install libtool Loaded plugins: rhnplugin, security This system is not reg...

RHEL6解决无法使用YUM源问题

RHEL6解决无法使用YUM源问题 RHEL的YUM源需要注册用户才能更新使用,由于CentOS和RHEL基本没有区别,并且CentOS已经被REHL收购。所以将RHEL的YUM源替换为CentOS...

解决redhat自带yum不能用的问题

解决redhat自带yum不能用的问题 [root@localhost ~]# yum install libtool Loaded plugins: rhnplugin, security Th...

redhat无法使用yum解决方案

CentOS 替换 RHEL 6.5 YUM源 首先删除 [root@rhel6 ~]# rpm -aq|grep yum|xargs rpm -e --nodeps 安装必要的...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)