HDOJ 4608 I-number

暴力枚举。。。

I-number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2803    Accepted Submission(s): 1065


Problem Description
The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1. y>x;
2. the sum of each digit of y(under base 10) is the multiple of 10;
3. among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.
 

Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 10 5.
 

Output
Output the I-number of x for each query.
 

Sample Input
  
  
1 202
 

Sample Output
  
  
208
 

Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

const int maxn=200100;

char str[maxn];

bool ck(char str[])
{
    int r=0;
    int n=strlen(str);
    for(int i=0;i<n;i++)
    {
        r+=(str[i]-'0')%10;
        r=r%10;
    }
    if(r%10==0) return true;
    return false;
}

bool PlusOne(char str[])
{
    int c=1;
    int n=strlen(str);
    for(int i=0;;i++)
    {
        if(i>=n) str[i]='0';
        int t=str[i]-'0';
        if(t+c<10)
        {
            str[i]++;
            c=0;
            break;
        }
        else
        {
            str[i]='0'+t+c-10;
            c=1;
        }
    }
    return true;
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        memset(str,0,sizeof(str));
        scanf("%s",str);
        reverse(str,str+strlen(str));
        while(PlusOne(str)) if(ck(str)) break;
        reverse(str,str+strlen(str));
        printf("%s\n",str);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值