HDOJ 4416 Good Article Good sentence


题解转自:http://blog.csdn.net/dyx404514/article/details/8807440

2012杭州网络赛的一道题,后缀数组后缀自动机都行吧。

题目大意:给一个字符串S和一系列字符串T1~Tn,问在S中有多少个不同子串满足它不是T1~Tn中任意一个字符串的子串。

 

思路:我们先构造S的后缀自动机,然后将每一个Ti在S的SAM上做匹配,类似于LCS,在S中的每一个状态记录一个变量deep,表示T1~Tn,在该状态能匹配的最大长度是多少,将每一个Ti匹配完之后,我们将S的SAM做拓扑排序,自底向上更新每个状态的deep,同时计算在该状态上有多少个子串满足题目要求。具体步骤如下:

1:对于当前状态,设为p,设p的par为q,则更新q->deep为q->deep和p->deep中的较大值。

2:若p->deep<p->val,则表示在状态p中,长度为p->deep+1~p->val的子串不是T1~Tn中任意字符串的子串,所以答案加上p->val-p->deep。否则表示状态p中所有字串均不满足要求,跳过即可。

(注意若p->deep==0,表示状态p中所有的子串均满足题目要求,但是答案不是加上p->val-0,而是加上 p->val-p->par->val,这表示状态p中的字符串个数,所以对于p->deep==0要特殊处理)

最后输出答案即可。




Good Article Good sentence

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2112    Accepted Submission(s): 587


Problem Description
In middle school, teachers used to encourage us to pick up pretty sentences so that we could apply those sentences in our own articles. One of my classmates ZengXiao Xian, wanted to get sentences which are different from that of others, because he thought the distinct pretty sentences might benefit him a lot to get a high score in his article.
Assume that all of the sentences came from some articles. ZengXiao Xian intended to pick from Article A. The number of his classmates is n. The i-th classmate picked from Article Bi. Now ZengXiao Xian wants to know how many different sentences she could pick from Article A which don't belong to either of her classmates?Article. To simplify the problem, ZengXiao Xian wants to know how many different strings, which is the substring of string A, but is not substring of either of string Bi. Of course, you will help him, won't you?
 

Input
The first line contains an integer T, the number of test data. 
For each test data
The first line contains an integer meaning the number of classmates.
The second line is the string A;The next n lines,the ith line input string Bi.
The length of the string A does not exceed 100,000 characters , The sum of total length of all strings Bi does not exceed 100,000, and assume all string consist only lowercase characters 'a' to 'z'.
 

Output
For each case, print the case number and the number of substrings that ZengXiao Xian can find.
 

Sample Input
  
  
3 2 abab ab ba 1 aaa bbb 2 aaaa aa aaa
 

Sample Output
  
  
Case 1: 3 Case 2: 3 Case 3: 1
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=110000;

struct SAM_Node
{
    SAM_Node *fa,*next[26];
    int len,id,pos;
    SAM_Node(){}
    SAM_Node(int _len)
    {
        len=_len;
        fa=0; memset(next,0,sizeof(next));
    }
};

SAM_Node SAM_node[maxn*2],*SAM_root,*SAM_last;
int SAM_size;

SAM_Node *newSAM_Node(int len)
{
    SAM_node[SAM_size]=SAM_Node(len);
    SAM_node[SAM_size].id=SAM_size;
    return &SAM_node[SAM_size++];
}

SAM_Node *newSAM_Node(SAM_Node *p)
{
    SAM_node[SAM_size]=*p;
    SAM_node[SAM_size].id=SAM_size;
    return &SAM_node[SAM_size++];
}

void SAM_init()
{
    SAM_size=0;
    SAM_root=SAM_last=newSAM_Node(0);
    SAM_node[0].pos=0;
}

void SAM_add(int x,int len)
{
    SAM_Node *p=SAM_last,*np=newSAM_Node(p->len+1);
    np->pos=len; SAM_last=np;
    for(;p&&!p->next[x];p=p->fa)
        p->next[x]=np;
    if(!p)
    {
        np->fa=SAM_root;
        return ;
    }
    SAM_Node *q=p->next[x];
    if(q->len==p->len+1)
    {
        np->fa=q;
        return ;
    }
    SAM_Node *nq=newSAM_Node(q);
    nq->len=p->len+1;
    q->fa=nq; np->fa=nq;
    for(;p&&p->next[x]==q;p=p->fa)
        p->next[x]=nq;
}

char A[maxn],B[maxn];
int c[maxn*2],LCS[maxn*2];
SAM_Node *top[maxn*2];

int main()
{
    int T_T,T,cas=1;
    scanf("%d",&T_T);
    while(T_T--)
    {
        scanf("%d",&T);
        scanf("%s",A);
        int len=strlen(A);
        SAM_init();
        for(int i=0;i<len;i++)
            SAM_add(A[i]-'a',i+1);

        memset(c,0,sizeof(c));
        memset(LCS,0,sizeof(LCS));
        memset(top,0,sizeof(top));

        for(int i=0;i<SAM_size;i++)
            c[SAM_node[i].len]++;
        for(int i=1;i<=len;i++)
            c[i]+=c[i-1];
        for(int i=0;i<SAM_size;i++)
            top[--c[SAM_node[i].len]]=&SAM_node[i];
        while(T--)
        {
            scanf("%s",B);
            int len2=strlen(B);
            int temp=0; SAM_Node *now=SAM_root;

            for(int i=0;i<len2;i++)
            {
                int x=B[i]-'a';
                if(now->next[x])
                {
                    temp++;
                    now=now->next[x];
                    LCS[now->id]=max(LCS[now->id],temp);
                }
                else
                {
                    while(now&&!now->next[x])
                        now=now->fa;
                    if(now)
                    {
                        temp=now->len+1;
                        now=now->next[x];
                        LCS[now->id]=max(LCS[now->id],temp);
                    }
                    else
                    {
                        temp=0; now=SAM_root;
                    }
                }
            }
        }
        long long int ans=0;
        for(int i=SAM_size-1;i>=1;i--)
        {
            SAM_Node *p=top[i];
            if(LCS[p->id])
            {
                if(p->fa)
                    LCS[p->fa->id]=max(LCS[p->fa->id],LCS[p->id]);
                if(LCS[p->id]<p->len)
                {
                    ans+=p->len-LCS[p->id];
                }
            }
            else
            {
                ans+=p->len-p->fa->len;
            }
        }
        printf("Case %d: %I64d\n",cas++,ans);
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值