关闭

vs2013编译cocos2d-x2.2.0所遇到的问题

标签: vs2013cocos2d-x2.2.0pthread
243人阅读 评论(1) 收藏 举报
分类:

  vs2013编译cocos2d-x报错:如果使用vs2013,编译项目会出错,报错为:std::min, std::max.  min max非std命名空间成员       

  则在报错的文件中添加头文件: #include <algorithm>

   cocos2d-x中使用pthread线程库:

    

.库文件

一样的,右键项目→属性→配置属性→链接器→输入→附加依赖项,添加pthreadVCE2.lib即可。v2.2.0会自动包含,这步可省。


1
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:21272次
    • 积分:750
    • 等级:
    • 排名:千里之外
    • 原创:54篇
    • 转载:5篇
    • 译文:0篇
    • 评论:15条
    座右铭

    细节决定成败,

    态度决定一切。

    最新评论